classification
Title: Test_tcl.TclTest.test_split(list) failures on Windows, 2.7.
Type: behavior Stage: resolved
Components: Tkinter Versions: Python 2.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Tkinter tests ran with wantobjects is false
View: 19320
Assigned To: Nosy List: jkloth, serhiy.storchaka, terry.reedy
Priority: normal Keywords:

Created on 2014-01-29 20:14 by terry.reedy, last changed 2014-01-30 17:53 by serhiy.storchaka. This issue is now closed.

Messages (4)
msg209671 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2014-01-29 20:14
My Win7, AMD64 Win7, Server 2003, but not x86 Win7 buildbot or any others that run test
======================================================================
FAIL: test_split (test.test_tcl.TclTest)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "C:\buildbot.python.org\2.7.kloth-win64\build\lib\test\test_tcl.py", line 321, in test_split
    self.assertEqual(split(arg), res)
AssertionError: Tuples differ: ('12', u'\u20ac', u'\u20ac', '... != (12, u'\u20ac', u'\u20ac', (3....

First differing element 0:
12
12

- ('12', u'\u20ac', u'\u20ac', '3.4')
?  -  -                        ^   ^

+ (12, u'\u20ac', u'\u20ac', (3.4,))
?                            ^   ^ +


======================================================================
FAIL: test_splitlist (test.test_tcl.TclTest)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "C:\buildbot.python.org\2.7.kloth-win64\build\lib\test\test_tcl.py", line 281, in test_splitlist
    self.assertEqual(splitlist(arg), res)
AssertionError: Tuples differ: ('1', u'\u20ac', u'\u20ac', '3... != (1, u'\u20ac', u'\u20ac', (3.4...

First differing element 0:
1
1

- ('1', u'\u20ac', u'\u20ac', '3.4')
?  - -                        ^   ^

+ (1, u'\u20ac', u'\u20ac', (3.4,))
?                           ^   ^ +
========================================
I do not know which is correct and which wrong.
msg209672 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2014-01-29 20:18
What is Tcl/Tk patchlevel? It is reported somewhere in tests log.
msg209673 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2014-01-29 20:39
I am running tcl8.5.2.1 and tk8.5.2.0 as installed by Tools/buildbots/external.bat. I presume same for Windows buildbots. I did not find 'tcl' or 'tk' other than in test names in the log I checked.
msg209679 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2014-01-29 20:53
This is a duplicate of issue19320.
History
Date User Action Args
2014-01-30 17:53:02serhiy.storchakasetstatus: open -> closed
stage: needs patch -> resolved
2014-01-29 22:21:09jklothsetnosy: + jkloth
2014-01-29 20:53:26serhiy.storchakasetsuperseder: Tkinter tests ran with wantobjects is false
resolution: duplicate
messages: + msg209679
2014-01-29 20:39:11terry.reedysetmessages: + msg209673
2014-01-29 20:18:23serhiy.storchakasetmessages: + msg209672
2014-01-29 20:14:47terry.reedycreate