classification
Title: Typo in cStringIO tp_name
Type: behavior Stage:
Components: Library (Lib) Versions: Python 2.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: mailination, vstinner
Priority: normal Keywords:

Created on 2014-01-24 17:11 by mailination, last changed 2014-01-24 17:17 by vstinner. This issue is now closed.

Messages (2)
msg209099 - (view) Author: (mailination) Date: 2014-01-24 17:11
python/Modules/cStringIO.c:648

  "cStringIO.StringI",                        /*tp_name*/

maybe Should be

  "cStringIO.StringIO",                        /*tp_name*/
msg209101 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2014-01-24 17:17
I don't think that it is a typo. cStringIO.StringIO(str) returns a "StringI" object, whereas cStringIO.StringIO() returns a "StringO" object.

$ python
Python 2.7.5 (default, Nov 12 2013, 16:45:54) 
[GCC 4.8.2 20131017 (Red Hat 4.8.2-1)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import cStringIO
>>> cStringIO.StringIO('abc')
<cStringIO.StringI object at 0x7f407d1dae88>
>>> cStringIO.StringIO()
<cStringIO.StringO object at 0x7f407d0f4e68>
History
Date User Action Args
2014-01-24 17:17:37vstinnersetstatus: open -> closed

nosy: + vstinner
messages: + msg209101

resolution: not a bug
2014-01-24 17:11:01mailinationcreate