classification
Title: win32pdh.EnumObjects fails on Windows Server 2003 R2
Type: crash Stage:
Components: Extension Modules Versions: Python 2.5
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: amaury.forgeotdarc, rmason
Priority: normal Keywords:

Created on 2008-02-07 15:05 by rmason, last changed 2008-02-07 15:26 by amaury.forgeotdarc. This issue is now closed.

Messages (2)
msg62152 - (view) Author: Richard Mason (rmason) Date: 2008-02-07 15:05
The following test script works OK on all windows platforms apart from 
Windows Server 2003 R2:

import win32pdh
win32pdh.EnumObjects(None, None, 0, 1)

When I run on Windows Server 2003 R2 get the following dump:

E:\fusiondx\lib>test.py
Traceback (most recent call last):
  File "E:\fusiondx\lib\test.py", line 2, in <module>
    win32pdh.EnumObjects(None, None, 0, 1)
pywintypes.error: (-2147481648, 'EnumObjects for buffer size', 'No 
error message is available')
msg62153 - (view) Author: Amaury Forgeot d'Arc (amaury.forgeotdarc) * (Python committer) Date: 2008-02-07 15:26
A quick google search on "2147481648" reveals that you are not alone:
http://mail.python.org/pipermail/python-win32/2004-October/002519.html

In addition, this tracker only deals with core python. I close the
issue. Please discuss this problem on the pywin32 web site:
http://starship.python.net/crew/mhammond/win32/
History
Date User Action Args
2008-02-07 15:26:26amaury.forgeotdarcsetstatus: open -> closed
resolution: not a bug
messages: + msg62153
nosy: + amaury.forgeotdarc
2008-02-07 15:05:50rmasoncreate