classification
Title: Argument Clinic docs do not list support for the 'l' format
Type: Stage: needs patch
Components: Documentation Versions: Python 3.4
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Argument Clinic: missing entry in table mapping legacy convertors to real AC converters
View: 20346
Assigned To: larry Nosy List: brett.cannon, larry, taleinat
Priority: normal Keywords:

Created on 2014-01-21 16:32 by brett.cannon, last changed 2014-01-22 21:26 by brett.cannon. This issue is now closed.

Messages (4)
msg208667 - (view) Author: Brett Cannon (brett.cannon) * (Python committer) Date: 2014-01-21 16:32
'l' is long for PyArg_ParseTuple().
msg208729 - (view) Author: Larry Hastings (larry) * (Python committer) Date: 2014-01-22 01:36
/*[clinic input]
brett_is_stinky_and_wrong

    l: long

[clinic start generated code]*/

PyDoc_STRVAR(brett_is_stinky_and_wrong__doc__,
"brett_is_stinky_and_wrong(l)");

#define BRETT_IS_STINKY_AND_WRONG_METHODDEF    \
    {"brett_is_stinky_and_wrong", (PyCFunction)brett_is_stinky_and_wrong, METH_VARARGS|METH_KEYWORDS, brett_is_stinky_and_wrong__doc__},

static PyObject *
brett_is_stinky_and_wrong_impl(PyModuleDef *module, long l);

static PyObject *
brett_is_stinky_and_wrong(PyModuleDef *module, PyObject *args, PyObject *kwargs)
{
    PyObject *return_value = NULL;
    static char *_keywords[] = {"l", NULL};
    long l;

    if (!PyArg_ParseTupleAndKeywords(args, kwargs,
        "l:brett_is_stinky_and_wrong", _keywords,
        &l))
        goto exit;
    return_value = brett_is_stinky_and_wrong_impl(module, l);

exit:
    return return_value;
}

static PyObject *
brett_is_stinky_and_wrong_impl(PyModuleDef *module, long l)
/*[clinic end generated code: checksum=d16330187341a0ecea0bf7ab70ba5551200ceb3c]*/
msg208823 - (view) Author: Brett Cannon (brett.cannon) * (Python committer) Date: 2014-01-22 16:37
So the docs don't mention this support anywhere. The 'l' format isn't listed in the table of legacy to Argument Clinic converters, nor is there a list of converters that only exist in Argument Clinic. So unless I read the section on return converters and inferred that if a return converter exists for long it exists as a argument converter I had no way of knowing the existence of long as a converter without reading the code.

So this is at least a doc bug.
msg208845 - (view) Author: Tal Einat (taleinat) * (Python committer) Date: 2014-01-22 20:03
See documentation patch for this issue attached to issue20346 (a duplicate of this).
History
Date User Action Args
2014-01-22 21:26:04brett.cannonsetsuperseder: Argument Clinic docs do not list support for the 'l' format -> Argument Clinic: missing entry in table mapping legacy convertors to real AC converters
2014-01-22 21:26:04brett.cannonunlinkissue20332 superseder
2014-01-22 21:25:39brett.cannonsetstatus: open -> closed
resolution: duplicate
2014-01-22 21:25:03brett.cannonsetsuperseder: Argument Clinic docs do not list support for the 'l' format
2014-01-22 21:25:03brett.cannonlinkissue20332 superseder
2014-01-22 20:03:17taleinatsetnosy: + taleinat
messages: + msg208845
2014-01-22 16:37:18brett.cannonsetstatus: closed -> open

components: + Documentation, - Build
title: Argument Clinic does not support the 'l' format -> Argument Clinic docs do not list support for the 'l' format
messages: + msg208823
type: behavior ->
resolution: not a bug -> (no value)
stage: resolved -> needs patch
2014-01-22 15:51:44serhiy.storchakalinkissue20346 superseder
2014-01-22 01:36:24larrysetstatus: open -> closed
type: behavior
messages: + msg208729

resolution: not a bug
stage: resolved
2014-01-21 16:32:04brett.cannoncreate