classification
Title: UserDict module docs link is obsolete
Type: Stage: resolved
Components: Documentation Versions: Python 2.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder: pydoc generates invalid docs.python.org link for xml.etree.ElementTree and other modules
View: 16484
Assigned To: docs@python Nosy List: docs@python, drunax, ezio.melotti, ned.deily, sean.rodman, westley.martinez
Priority: normal Keywords: easy

Created on 2014-01-06 15:19 by drunax, last changed 2014-02-25 00:41 by ned.deily. This issue is now closed.

Messages (3)
msg207441 - (view) Author: Alexandru Gheorghe (drunax) Date: 2014-01-06 15:19
FILE
    /usr/lib/python2.7/UserDict.py

MODULE DOCS
    http://docs.python.org/library/UserDict



Reference link to online documentation is invalid. (Probably) Should be: http://docs.python.org/library/userdict.html


Happens on Debian 7 Wheezy x86_64: 
Python 2.7.3 , [GCC 4.7.2] on linux2
msg212148 - (view) Author: Sean Rodman (sean.rodman) * Date: 2014-02-24 22:38
Hey drunax, I would like to create a patch for this and upload, but I don't see the link you are talking about. Is it in the documentation or is it in the file UserDict.py?
msg212152 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2014-02-25 00:41
This problem is a duplicate of Issue16484.

The URL is generated by pydoc's getdocloc() when you use pydoc explicitly or through the interactive interpreter's help command.  But the doc web server is not set up to handle links for modules with mixed-case names, like UserDict; http://docs.python.org/2/library/userdict works.  Sean, you can add yourself to Issue16484 if you'd like to help.
History
Date User Action Args
2014-02-25 00:41:37ned.deilysetstatus: open -> closed

superseder: pydoc generates invalid docs.python.org link for xml.etree.ElementTree and other modules
nosy: + ned.deily

messages: + msg212152
type: enhancement ->
resolution: duplicate
stage: needs patch -> resolved
2014-02-24 22:38:49sean.rodmansetnosy: + sean.rodman
messages: + msg212148
2014-02-18 00:49:22westley.martinezsetnosy: + westley.martinez
2014-02-15 15:27:05ezio.melottisetkeywords: + easy
nosy: + ezio.melotti

stage: needs patch
2014-01-06 15:19:43drunaxcreate