classification
Title: SimpleHTTPServer: UnicodeDecodeError on Windows 8 (64-bit)
Type: Stage:
Components: Unicode, Windows Versions: Python 2.7
process
Status: closed Resolution: fixed
Dependencies: Superseder: mimetypes initialization fails on Windows because of non-Latin characters in registry
View: 9291
Assigned To: Nosy List: Hugo.Lol, ezio.melotti, vstinner
Priority: normal Keywords:

Created on 2013-12-18 16:33 by Hugo.Lol, last changed 2013-12-18 16:34 by vstinner. This issue is now closed.

Messages (2)
msg206538 - (view) Author: (Hugo.Lol) Date: 2013-12-18 16:33
Running Windows 8 (64-bit) and Python 2.7.6 (64-bit).

> python -m SimpleHTTPServer
Traceback (most recent call last):
  File "C:\Python27\lib\runpy.py", line 162, in _run_module_as_main
    "__main__", fname, loader, pkg_name)
  File "C:\Python27\lib\runpy.py", line 72, in _run_code
    exec code in run_globals
  File "C:\Python27\lib\SimpleHTTPServer.py", line 27, in <module>
    class SimpleHTTPRequestHandler(BaseHTTPServer.BaseHTTPRequestHandler):
  File "C:\Python27\lib\SimpleHTTPServer.py", line 208, in SimpleHTTPRequestHand
ler
    mimetypes.init() # try to read system mime.types
  File "C:\Python27\lib\mimetypes.py", line 358, in init
    db.read_windows_registry()
  File "C:\Python27\lib\mimetypes.py", line 258, in read_windows_registry
    for subkeyname in enum_types(hkcr):
  File "C:\Python27\lib\mimetypes.py", line 249, in enum_types
    ctype = ctype.encode(default_encoding) # omit in 3.x!
UnicodeDecodeError: 'ascii' codec can't decode byte 0xd7 in position 2: ordinal
not in range(128)
msg206539 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2013-12-18 16:34
This issue is a duplicate of #9291.
History
Date User Action Args
2013-12-18 16:34:51vstinnersetstatus: open -> closed
superseder: mimetypes initialization fails on Windows because of non-Latin characters in registry
resolution: fixed
messages: + msg206539
2013-12-18 16:33:28Hugo.Lolcreate