classification
Title: test_venv: test_with_pip() failure on "AMD64 Windows Server 2008 [SB] 3.x" buildbot
Type: Stage:
Components: Tests Versions: Python 3.4
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: Nosy List: dstufft, larry, ncoghlan, vstinner
Priority: high Keywords: buildbot

Created on 2013-11-25 11:30 by vstinner, last changed 2014-02-18 11:33 by vstinner. This issue is now closed.

Messages (3)
msg204325 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2013-11-25 11:30
This issue looks like issue #19734, but I'm not sure, so I prefer to open a new issue. Don't hesitate to close it as a duplicate of it's the same.

http://buildbot.python.org/all/builders/AMD64%20Windows%20Server%202008%20%5BSB%5D%203.x/builds/1752/steps/test/logs/stdio

test_with_pip (test.test_venv.EnsurePipTest) ... FAIL

======================================================================
FAIL: test_with_pip (test.test_venv.EnsurePipTest)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "E:\home\cpython\buildslave\x64\3.x.snakebite-win2k8r2sp1-amd64\build\lib\test\test_venv.py", line 314, in test_with_pip
    self.assertEqual(err, "")
AssertionError: "C:\\Users\\BUILDS~1\\AppData\\Local\\Tem[138 chars]\r\n" != ''
- C:\Users\BUILDS~1\AppData\Local\Temp\tmpa0ocjb9d\Scripts\python_d.exe: No module named 'pip._vendor.requests.adapters'; 'pip' is a package and cannot be directly executed
msg204335 - (view) Author: Nick Coghlan (ncoghlan) * (Python committer) Date: 2013-11-25 12:40
So, the last part of the error message is just runpy getting confused because attempting to import pip.__main__ threw ImportError (it should check the ImportError name (see issue 19771).

I'm not sure about the first part though - I'm not sure why the pip wheel would lose track of a submodule like that.
msg210991 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2014-02-11 17:48
I didn't see this error recently, can I close the issue?
History
Date User Action Args
2014-02-18 11:33:38vstinnersetstatus: open -> closed
resolution: fixed
2014-02-11 17:48:55vstinnersetmessages: + msg210991
2013-11-25 12:40:10ncoghlansetpriority: normal -> high
versions: + Python 3.4
nosy: + larry, dstufft

messages: + msg204335
2013-11-25 11:30:05vstinnercreate