classification
Title: Check if unittest.mock needs updating for PEP 451
Type: Stage:
Components: Library (Lib) Versions: Python 3.4
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: Arfrever, brett.cannon, eric.snow, ezio.melotti, michael.foord, ncoghlan
Priority: normal Keywords:

Created on 2013-11-22 16:41 by brett.cannon, last changed 2013-12-02 15:18 by brett.cannon. This issue is now closed.

Messages (2)
msg204969 - (view) Author: Michael Foord (michael.foord) * (Python committer) Date: 2013-12-01 21:43
It shouldn't do, so long as __import__ supports PEP 451. unittest.mock.patch uses __import__ to find modules specified by name.
msg205016 - (view) Author: Brett Cannon (brett.cannon) * (Python committer) Date: 2013-12-02 15:18
Based on what Michael said there is nothing to update.
History
Date User Action Args
2013-12-02 15:18:59brett.cannonsetstatus: open -> closed
resolution: not a bug
messages: + msg205016
2013-12-01 21:43:28michael.foordsetmessages: + msg204969
2013-11-25 03:47:46ezio.melottisetnosy: + ezio.melotti, michael.foord
2013-11-23 19:52:14Arfreversetnosy: + Arfrever
2013-11-22 16:41:39brett.cannonlinkissue18864 dependencies
2013-11-22 16:41:00brett.cannoncreate