classification
Title: test_venv failing on one of the Ubuntu buildbots
Type: behavior Stage: resolved
Components: Library (Lib) Versions: Python 3.4
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: Nosy List: larry, ncoghlan, python-dev
Priority: release blocker Keywords: buildbot

Created on 2013-11-22 15:09 by ncoghlan, last changed 2013-11-24 06:51 by ncoghlan. This issue is now closed.

Messages (5)
msg203778 - (view) Author: Nick Coghlan (ncoghlan) * (Python committer) Date: 2013-11-22 15:09
pip still relies on imp (due to cross-version compatibility requirements), so it may trigger a pending deprecation warning, and potentially return a non-zero return code:

http://buildbot.python.org/all/builders/AMD64%20Ubuntu%20LTS%203.x/builds/3142/steps/test/logs/stdio
msg203946 - (view) Author: Nick Coghlan (ncoghlan) * (Python committer) Date: 2013-11-23 01:33
Reviewing the current buildbot failures, this is still the only one reporting the error:

http://buildbot.python.org/all/builders/AMD64%20Ubuntu%20LTS%203.x/builds/3165/steps/test/logs/stdio

I can reproduce the failure locally by running:

$ PYTHONWARNINGS=d ./python -m test test_venv
[1/1] test_venv
/home/ncoghlan/devel/py3k/Lib/imp.py:32: PendingDeprecationWarning: the imp module is deprecated in favour of importlib; see the module's documentation for alternative uses
  PendingDeprecationWarning)
/tmp/tmpwmsqtb9y/pip-1.5.rc1-py2.py3-none-any.whl/pip/wheel.py:127: DeprecationWarning: This method will be removed in future versions.  Use 'parser.read_file()' instead.
test test_venv failed -- Traceback (most recent call last):
  File "/home/ncoghlan/devel/py3k/Lib/test/test_venv.py", line 289, in test_with_pip
    self.assertEqual(err, b"")
AssertionError: b"/home/ncoghlan/devel/py3k/Lib/imp.py:32:[160 chars]g)\n" != b''

1 test failed:
    test_venv

I'm updating the test to make sure that venv runs the subprocess in isolated mode.
msg203948 - (view) Author: Roundup Robot (python-dev) (Python triager) Date: 2013-11-23 01:38
New changeset 0ce8d68181a2 by Nick Coghlan in branch 'default':
Close #19694: venv now runs ensurepip in isolated mode
http://hg.python.org/cpython/rev/0ce8d68181a2
msg204048 - (view) Author: Larry Hastings (larry) * (Python committer) Date: 2013-11-23 16:34
Are you sure the problem is fixed?  I still see the same error on the same buildbot.

http://buildbot.python.org/all/builders/AMD64%20Ubuntu%20LTS%203.x/builds/3168/steps/test/logs/stdio
msg204183 - (view) Author: Nick Coghlan (ncoghlan) * (Python committer) Date: 2013-11-24 06:51
Using isolated mode addressed the warning noise, issue 19734 covers additional environment dependent problems in the test.
History
Date User Action Args
2013-11-24 06:51:16ncoghlansetmessages: + msg204183
2013-11-23 16:34:49larrysetmessages: + msg204048
2013-11-23 01:38:25python-devsetstatus: open -> closed

nosy: + python-dev
messages: + msg203948

resolution: fixed
stage: needs patch -> resolved
2013-11-23 01:33:39ncoghlansetmessages: + msg203946
2013-11-22 15:09:41ncoghlancreate