classification
Title: test_tkinter sporadic skipped on "x86 Tiger 3.x" buildbot
Type: Stage:
Components: macOS, Tkinter Versions: Python 3.4
process
Status: closed Resolution: out of date
Dependencies: Superseder:
Assigned To: Nosy List: db3l, ned.deily, python-dev, ronaldoussoren, serhiy.storchaka, vstinner
Priority: normal Keywords: buildbot, patch

Created on 2013-11-19 13:44 by vstinner, last changed 2015-03-18 11:08 by vstinner. This issue is now closed.

Files
File name Uploaded Description Edit
test_tcl_patchlevel.patch serhiy.storchaka, 2013-11-19 19:49 review
Messages (9)
msg203374 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2013-11-19 13:44
http://buildbot.python.org/all/builders/x86%20Tiger%203.x/builds/7331/steps/test/logs/stdio

======================================================================
FAIL: test_debug (tkinter.test.test_tkinter.test_text.TextTest)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/Users/db3l/buildarea/3.x.bolen-tiger/build/Lib/tkinter/test/test_tkinter/test_text.py", line 22, in test_debug
    self.assertEqual(text.debug(), 0)
AssertionError: '0' != 0

======================================================================
FAIL: test_insertborderwidth (tkinter.test.test_tkinter.test_widgets.EntryTest)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/Users/db3l/buildarea/3.x.bolen-tiger/build/Lib/tkinter/test/test_tkinter/test_widgets.py", line 329, in test_insertborderwidth
    self.checkPixelsParam(widget, 'insertborderwidth', 0, 1.3, -2)
  File "/Users/db3l/buildarea/3.x.bolen-tiger/build/Lib/tkinter/test/widget_tests.py", line 167, in checkPixelsParam
    conv=conv1, **kwargs)
  File "/Users/db3l/buildarea/3.x.bolen-tiger/build/Lib/tkinter/test/widget_tests.py", line 57, in checkParam
    self.assertEqual2(widget[name], expected, eq=eq)
  File "/Users/db3l/buildarea/3.x.bolen-tiger/build/Lib/tkinter/test/widget_tests.py", line 41, in assertEqual2
    self.assertEqual(actual, expected, msg)
AssertionError: 0 != 1

======================================================================
FAIL: test_insertborderwidth (tkinter.test.test_tkinter.test_widgets.SpinboxTest)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/Users/db3l/buildarea/3.x.bolen-tiger/build/Lib/tkinter/test/test_tkinter/test_widgets.py", line 329, in test_insertborderwidth
    self.checkPixelsParam(widget, 'insertborderwidth', 0, 1.3, -2)
  File "/Users/db3l/buildarea/3.x.bolen-tiger/build/Lib/tkinter/test/widget_tests.py", line 167, in checkPixelsParam
    conv=conv1, **kwargs)
  File "/Users/db3l/buildarea/3.x.bolen-tiger/build/Lib/tkinter/test/widget_tests.py", line 57, in checkParam
    self.assertEqual2(widget[name], expected, eq=eq)
  File "/Users/db3l/buildarea/3.x.bolen-tiger/build/Lib/tkinter/test/widget_tests.py", line 41, in assertEqual2
    self.assertEqual(actual, expected, msg)
AssertionError: 0 != 1
msg203383 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2013-11-19 14:38
There's something odd going on with that buildbot.  The failures are from Serhly's new tests.  For 10.4 Tiger, the buildbot should be running Tk 8.4.  It does seem to have a third-party Tcl and Tk installed in /Library/Frameworks, which is good, but the logs don't show exactly what patch level it is.  David, can you identify what patch levels of Tcl and Tk are installed?  more /Library/Frameworks/Tcl.framework/tclConfig.sh /Library/Frameworks/Tk.framework/tkConfig.sh should work.
msg203417 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2013-11-19 19:49
We can add a print for a patchlevel.
msg203493 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2013-11-20 15:28
The failures are sporadic, I don't understand how the tests can pass sometimes...
msg203495 - (view) Author: Roundup Robot (python-dev) (Python triager) Date: 2013-11-20 15:44
New changeset 74b76a726285 by Serhiy Storchaka in branch '3.3':
Print Tk patchlevel in test_tcl in verbose mode (issue19654).
http://hg.python.org/cpython/rev/74b76a726285

New changeset 1b58f14f5d60 by Serhiy Storchaka in branch 'default':
Print Tk patchlevel in test_tcl in verbose mode (issue19654).
http://hg.python.org/cpython/rev/1b58f14f5d60

New changeset 78c906600183 by Serhiy Storchaka in branch '2.7':
Print Tk patchlevel in test_tcl in verbose mode (issue19654).
http://hg.python.org/cpython/rev/78c906600183
msg203656 - (view) Author: Roundup Robot (python-dev) (Python triager) Date: 2013-11-21 17:24
New changeset cfbd894f1df1 by Serhiy Storchaka in branch '3.3':
Print Tk patchlevel in Tk and Ttk tests in verbose mode (issue19654).
http://hg.python.org/cpython/rev/cfbd894f1df1

New changeset cf8ac1272e07 by Serhiy Storchaka in branch 'default':
Print Tk patchlevel in Tk and Ttk tests in verbose mode (issue19654).
http://hg.python.org/cpython/rev/cf8ac1272e07

New changeset 08f282c96fd1 by Serhiy Storchaka in branch '2.7':
Print Tk patchlevel in Tk and Ttk tests in verbose mode (issue19654).
http://hg.python.org/cpython/rev/08f282c96fd1
msg204319 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2013-11-25 09:59
http://buildbot.python.org/all/builders/x86%20Tiger%203.x/builds/7408/steps/test/logs/stdio

patchlevel = 8.4.19

Does it help to know the full version?
msg209877 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2014-02-01 07:07
The failures in test_tk here are the same ones documented in Issue19761 for Tk 8.4 so this issue could be closed as a duplicate of that one.  The mystery remains why test_tk appears to alternately pass and fail on this buildbot.  I don't see why it doesn't always fail.
msg209974 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2014-02-02 12:02
> The mystery remains why test_tk appears to alternately pass and fail on this buildbot.  I don't see why it doesn't always fail.

test_tk not fails in case when it is just skipped. And why it is sporadic skipped, this is very interesting question.
History
Date User Action Args
2015-03-18 11:08:09vstinnersetstatus: open -> closed
resolution: out of date
2014-02-02 12:02:49serhiy.storchakasetmessages: + msg209974
title: test_tkinter sporadic failures on "x86 Tiger 3.x" buildbot -> test_tkinter sporadic skipped on "x86 Tiger 3.x" buildbot
2014-02-01 07:08:38ned.deilysetassignee: ronaldoussoren ->
2014-02-01 07:07:49ned.deilysetmessages: + msg209877
2013-11-25 09:59:11vstinnersetmessages: + msg204319
2013-11-21 17:24:32python-devsetmessages: + msg203656
2013-11-20 15:44:57python-devsetnosy: + python-dev
messages: + msg203495
2013-11-20 15:28:33vstinnersetmessages: + msg203493
2013-11-19 19:49:58serhiy.storchakasetfiles: + test_tcl_patchlevel.patch
keywords: + patch
messages: + msg203417
2013-11-19 14:39:24ned.deilysetnosy: + db3l
2013-11-19 14:38:04ned.deilysetnosy: + ned.deily
messages: + msg203383
2013-11-19 14:02:28zach.waresetnosy: + serhiy.storchaka
2013-11-19 13:44:01vstinnercreate