classification
Title: test_sysconfig_module fails on Ubuntu 12.04
Type: behavior Stage: resolved
Components: Distutils, Tests Versions: Python 3.3, Python 3.4
process
Status: closed Resolution: out of date
Dependencies: Superseder:
Assigned To: Nosy List: Avichal.Dayal, barry, berker.peksag, terry.reedy
Priority: normal Keywords:

Created on 2013-11-16 00:37 by berker.peksag, last changed 2014-01-28 05:30 by berker.peksag. This issue is now closed.

Messages (6)
msg202994 - (view) Author: Berker Peksag (berker.peksag) * (Python committer) Date: 2013-11-16 00:37
This is probably related to issue 17679.

======================================================================
FAIL: test_sysconfig_module (distutils.tests.test_sysconfig.SysconfigTestCase)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/berker/projects/cpython/Lib/distutils/tests/test_sysconfig.py", line 132, in test_sysconfig_module
    self.assertEqual(global_sysconfig.get_config_var('CFLAGS'), sysconfig.get_config_var('CFLAGS'))
AssertionError: '-Wno-unused-result -g -O0 -Wall -Wstrict-prototypes' != '-Wno-unused-result -Werror=declaration-after-statement -g -O0[22 chars]ypes'
- -Wno-unused-result -g -O0 -Wall -Wstrict-prototypes
+ -Wno-unused-result -Werror=declaration-after-statement -g -O0 -Wall -Wstrict-prototypes
msg203116 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2013-11-17 03:55
Please add system/os/py-version info. On my Win7-64 machine,
C:\Programs\Python34>python -m test -v test_sysconfig
C:\Programs\Python34>python -m distutils.tests.test_sysconfig
both pass (and run slightly different sets of tests).
msg203117 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2013-11-17 03:57
Sorry, about system comment. Got here by link on mail list and read message, not title. Py version is still relevant, as one should try latest releases before reporting.
msg203131 - (view) Author: Avichal Dayal (Avichal.Dayal) Date: 2013-11-17 09:57
On my system Ubuntu 12.04 -64bit
./python -m test -v test_sysconfig
./python -m distutils/tests/test_sysconfig
both run fine
msg203307 - (view) Author: Barry A. Warsaw (barry) * (Python committer) Date: 2013-11-18 16:19
I also can't reproduce this in Python 3.3 or 3.4 on Trusty Tahr (what will be Ubuntu 14.04).
msg209501 - (view) Author: Berker Peksag (berker.peksag) * (Python committer) Date: 2014-01-28 05:30
The cause of the test failure was the Lib/_sysconfigdata.py file which is created by the _generate_posix_vars() function in Lib/sysconfig.py. With a fresh copy of the repo and a clean build, all tests are passed.
History
Date User Action Args
2014-01-28 05:30:44berker.peksagsetstatus: open -> closed
resolution: out of date
messages: + msg209501

stage: resolved
2013-11-18 16:19:19barrysetmessages: + msg203307
2013-11-17 09:57:41Avichal.Dayalsetnosy: + Avichal.Dayal
messages: + msg203131
2013-11-17 03:57:50terry.reedysetmessages: + msg203117
2013-11-17 03:55:11terry.reedysetnosy: + terry.reedy
messages: + msg203116
2013-11-16 11:07:26pitrousetnosy: + barry
2013-11-16 00:37:03berker.peksagcreate