classification
Title: Enable all freebsd* host platforms
Type: enhancement Stage: resolved
Components: Build Versions: Python 3.3, Python 3.4, Python 2.7
process
Status: closed Resolution: out of date
Dependencies: 12619 Superseder: Remove Lib/plat-*/* files
View: 28027
Assigned To: Nosy List: Arfrever, koobs, lemburg, wg, zach.ware
Priority: normal Keywords: patch

Created on 2013-11-11 12:29 by wg, last changed 2016-09-09 16:48 by zach.ware. This issue is now closed.

Files
File name Uploaded Description Edit
tip.patch wg, 2013-11-11 12:32 review
Messages (6)
msg202621 - (view) Author: William Grzybowski (wg) * Date: 2013-11-11 12:29
Hello,

Currently python setup.py restricts FreeBSD host platform by version, e.g. freebsd7, freebsd8.

It is not only out-of-date (we already are on freebsd11) but also doesn't seem to have a good reason to do so.

Proposed patches replaces it with startswith('freebsd').

Thanks
msg202622 - (view) Author: Stefan Krah (skrah) * (Python committer) Date: 2013-11-11 12:51
The comment says that semaphores are broken up to FreeBSD-8, so
linking with -lrt is disabled. This looks correct to me and our
FreeBSD 9 and 10 buildbots work.

If you have a specific problem, please re-open the issue.
msg202623 - (view) Author: William Grzybowski (wg) * Date: 2013-11-11 12:55
Semaphores broken or not (it seems to work just fine in freebsd9) python is still usable overall.

I see no reason to arbitrarily chose what freebsd platform to build.
msg202625 - (view) Author: Stefan Krah (skrah) * (Python committer) Date: 2013-11-11 13:02
I looked at patch set 1, which actually *reduced* functionality for FreeBSD >= 9.

Now there is a second patch set, so I'm re-opening.
msg202626 - (view) Author: William Grzybowski (wg) * Date: 2013-11-11 13:06
Ah, I see, I made a misinterpretation of setup.py. Sorry about that.

So please ignore the setup.py changes in the patch ;)
msg275342 - (view) Author: Zachary Ware (zach.ware) * (Python committer) Date: 2016-09-09 16:48
The platform-specific modules have been removed.
History
Date User Action Args
2016-09-09 16:48:07zach.waresetstatus: open -> closed

superseder: Remove Lib/plat-*/* files

nosy: + zach.ware
messages: + msg275342
resolution: out of date
stage: resolved
2014-05-13 22:00:53skrahsetnosy: - skrah
2013-11-16 00:45:17terry.reedysetversions: - Python 2.6, Python 3.1, Python 3.2, Python 3.5
2013-11-12 07:48:40Arfreversetnosy: + Arfrever
2013-11-11 13:32:23skrahsetnosy: + lemburg
dependencies: + Automatically regenerate platform-specific modules
2013-11-11 13:06:50wgsetmessages: + msg202626
2013-11-11 13:04:16skrahsetstatus: closed -> open
resolution: not a bug -> (no value)
stage: resolved -> (no value)
2013-11-11 13:02:48skrahsetmessages: + msg202625
2013-11-11 12:55:15wgsetmessages: + msg202623
2013-11-11 12:52:01skrahsetstatus: open -> closed
2013-11-11 12:51:35skrahsetnosy: + skrah
messages: + msg202622

resolution: not a bug
stage: resolved
2013-11-11 12:44:16koobssetnosy: + koobs
2013-11-11 12:32:59wgsetfiles: - tip.patch
2013-11-11 12:32:46wgsetfiles: + tip.patch
2013-11-11 12:29:49wgcreate