classification
Title: NameError: global name 'basestring' is not defined
Type: Stage:
Components: Documentation Versions: Python 3.0
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: christian.heimes, georg.brandl, gvanrossum, loewis, rclark
Priority: low Keywords:

Created on 2008-01-25 00:11 by rclark, last changed 2008-01-26 09:44 by georg.brandl. This issue is now closed.

Messages (6)
msg61662 - (view) Author: Robert Clark (rclark) Date: 2008-01-25 00:11
File
"/home/rclark/lib/src/python/pyparsing/pyparsing-1.3.1/pyparsing.py",
line 1511, in __init__
    if isinstance( expr, basestring ):
NameError: global name 'basestring' is not defined
msg61665 - (view) Author: Robert Clark (rclark) Date: 2008-01-25 00:37
basestring is in the builtins library for 2.5.1, but is not there in 3.0a2

Linux: RHEL40
msg61666 - (view) Author: Guido van Rossum (gvanrossum) * (Python committer) Date: 2008-01-25 01:35
It's been deleted. Use 2to3; it will replace it with 'str'.
msg61672 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2008-01-25 05:47
Robert, can you please explain why you consider this as a bug?
msg61679 - (view) Author: Christian Heimes (christian.heimes) * (Python committer) Date: 2008-01-25 11:03
I've updated the whatsnew docs in r60279.
msg61702 - (view) Author: Georg Brandl (georg.brandl) * (Python committer) Date: 2008-01-26 09:44
I don't see why this shouldn't be closed.
History
Date User Action Args
2008-01-26 09:44:40georg.brandlsetstatus: pending -> closed
nosy: + georg.brandl
messages: + msg61702
2008-01-25 11:03:02christian.heimessetstatus: open -> pending
nosy: + christian.heimes
resolution: not a bug
messages: + msg61679
priority: low
2008-01-25 05:47:14loewissetnosy: + loewis
messages: + msg61672
2008-01-25 01:35:31gvanrossumsettype: compile error ->
messages: + msg61666
components: + Documentation
nosy: + gvanrossum
2008-01-25 00:37:23rclarksetmessages: + msg61665
2008-01-25 00:11:39rclarkcreate