classification
Title: test_io.test_interrupted_write_retry_text() hangs on Solaris 10 and FreeBSD 7.2
Type: Stage:
Components: Versions: Python 3.4
process
Status: closed Resolution: out of date
Dependencies: Superseder:
Assigned To: Nosy List: neologix, vstinner
Priority: normal Keywords:

Created on 2013-10-12 12:54 by vstinner, last changed 2015-03-18 11:07 by vstinner. This issue is now closed.

Messages (2)
msg199561 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2013-10-12 12:54
http://buildbot.python.org/all/builders/x86%20FreeBSD%207.2%203.x/builds/4531/steps/test/logs/stdio


[136/380] test_io
Timeout (1:00:00)!
Thread 0x28401040:
  File "/usr/home/db3l/buildarea/3.x.bolen-freebsd7/build/Lib/test/test_io.py", line 3215 in check_interrupted_write_retry
  File "/usr/home/db3l/buildarea/3.x.bolen-freebsd7/build/Lib/test/test_io.py", line 3237 in test_interrupted_write_retry_text
  File "/usr/home/db3l/buildarea/3.x.bolen-freebsd7/build/Lib/unittest/case.py", line 571 in run
  File "/usr/home/db3l/buildarea/3.x.bolen-freebsd7/build/Lib/unittest/case.py", line 610 in __call__
  File "/usr/home/db3l/buildarea/3.x.bolen-freebsd7/build/Lib/unittest/suite.py", line 117 in run
  File "/usr/home/db3l/buildarea/3.x.bolen-freebsd7/build/Lib/unittest/suite.py", line 79 in __call__
  File "/usr/home/db3l/buildarea/3.x.bolen-freebsd7/build/Lib/unittest/suite.py", line 117 in run
  File "/usr/home/db3l/buildarea/3.x.bolen-freebsd7/build/Lib/unittest/suite.py", line 79 in __call__
  File "/usr/home/db3l/buildarea/3.x.bolen-freebsd7/build/Lib/unittest/suite.py", line 117 in run
  File "/usr/home/db3l/buildarea/3.x.bolen-freebsd7/build/Lib/unittest/suite.py", line 79 in __call__
  File "/usr/home/db3l/buildarea/3.x.bolen-freebsd7/build/Lib/unittest/runner.py", line 168 in run
  File "/usr/home/db3l/buildarea/3.x.bolen-freebsd7/build/Lib/test/support/__init__.py", line 1661 in _run_suite
  File "/usr/home/db3l/buildarea/3.x.bolen-freebsd7/build/Lib/test/support/__init__.py", line 1695 in run_unittest
  File "/usr/home/db3l/buildarea/3.x.bolen-freebsd7/build/Lib/test/regrtest.py", line 1275 in <lambda>
  File "/usr/home/db3l/buildarea/3.x.bolen-freebsd7/build/Lib/test/regrtest.py", line 1276 in runtest_inner
  File "/usr/home/db3l/buildarea/3.x.bolen-freebsd7/build/Lib/test/regrtest.py", line 965 in runtest
  File "/usr/home/db3l/buildarea/3.x.bolen-freebsd7/build/Lib/test/regrtest.py", line 761 in main
  File "/usr/home/db3l/buildarea/3.x.bolen-freebsd7/build/Lib/test/regrtest.py", line 1560 in main_in_temp_cwd
  File "/usr/home/db3l/buildarea/3.x.bolen-freebsd7/build/Lib/test/__main__.py", line 3 in <module>
  File "/usr/home/db3l/buildarea/3.x.bolen-freebsd7/build/Lib/runpy.py", line 73 in _run_code
  File "/usr/home/db3l/buildarea/3.x.bolen-freebsd7/build/Lib/runpy.py", line 160 in _run_module_as_main


and

http://buildbot.python.org/all/builders/SPARC%20Solaris%2010%20%28cc%2C%2064b%29%20%5BSB%5D%203.x/builds/980/steps/test/logs/stdio

[324/377/2] test_io
Timeout (1:00:00)!
Thread 0x0000000000000001:
  File "/home/cpython/buildslave/cc-64/3.x.snakebite-sol10-sparc-cc-64/build/Lib/test/test_io.py", line 3215 in check_interrupted_write_retry
  File "/home/cpython/buildslave/cc-64/3.x.snakebite-sol10-sparc-cc-64/build/Lib/test/test_io.py", line 3237 in test_interrupted_write_retry_text
  File "/home/cpython/buildslave/cc-64/3.x.snakebite-sol10-sparc-cc-64/build/Lib/unittest/case.py", line 496 in run
  File "/home/cpython/buildslave/cc-64/3.x.snakebite-sol10-sparc-cc-64/build/Lib/unittest/case.py", line 535 in __call__
  File "/home/cpython/buildslave/cc-64/3.x.snakebite-sol10-sparc-cc-64/build/Lib/unittest/suite.py", line 105 in run
  File "/home/cpython/buildslave/cc-64/3.x.snakebite-sol10-sparc-cc-64/build/Lib/unittest/suite.py", line 67 in __call__
  File "/home/cpython/buildslave/cc-64/3.x.snakebite-sol10-sparc-cc-64/build/Lib/unittest/suite.py", line 105 in run
  File "/home/cpython/buildslave/cc-64/3.x.snakebite-sol10-sparc-cc-64/build/Lib/unittest/suite.py", line 67 in __call__
  File "/home/cpython/buildslave/cc-64/3.x.snakebite-sol10-sparc-cc-64/build/Lib/unittest/suite.py", line 105 in run
  File "/home/cpython/buildslave/cc-64/3.x.snakebite-sol10-sparc-cc-64/build/Lib/unittest/suite.py", line 67 in __call__
  File "/home/cpython/buildslave/cc-64/3.x.snakebite-sol10-sparc-cc-64/build/Lib/unittest/runner.py", line 168 in run
  File "/home/cpython/buildslave/cc-64/3.x.snakebite-sol10-sparc-cc-64/build/Lib/test/support/__init__.py", line 1624 in _run_suite
  File "/home/cpython/buildslave/cc-64/3.x.snakebite-sol10-sparc-cc-64/build/Lib/test/support/__init__.py", line 1658 in run_unittest
  File "/home/cpython/buildslave/cc-64/3.x.snakebite-sol10-sparc-cc-64/build/Lib/test/regrtest.py", line 1304 in <lambda>
  File "/home/cpython/buildslave/cc-64/3.x.snakebite-sol10-sparc-cc-64/build/Lib/test/regrtest.py", line 1305 in runtest_inner
  File "/home/cpython/buildslave/cc-64/3.x.snakebite-sol10-sparc-cc-64/build/Lib/test/regrtest.py", line 998 in runtest
  File "/home/cpython/buildslave/cc-64/3.x.snakebite-sol10-sparc-cc-64/build/Lib/test/regrtest.py", line 796 in main
  File "/home/cpython/buildslave/cc-64/3.x.snakebite-sol10-sparc-cc-64/build/Lib/test/regrtest.py", line 1590 in main_in_temp_cwd
  File "/home/cpython/buildslave/cc-64/3.x.snakebite-sol10-sparc-cc-64/build/Lib/test/__main__.py", line 3 in <module>
  File "/home/cpython/buildslave/cc-64/3.x.snakebite-sol10-sparc-cc-64/build/Lib/runpy.py", line 73 in _run_code
  File "/home/cpython/buildslave/cc-64/3.x.snakebite-sol10-sparc-cc-64/build/Lib/runpy.py", line 160 in _run_module_as_main
msg199580 - (view) Author: Charles-Fran├žois Natali (neologix) * (Python committer) Date: 2013-10-12 15:53
I think the problem is that those buildbots are really slow (just look at the second buildbot's backlog), and the signal is delivered before the large buffer is allocated, hence the write() syscall doesn't fail with EINTR.
History
Date User Action Args
2015-03-18 11:07:40vstinnersetstatus: open -> closed
resolution: out of date
2013-10-12 15:53:07neologixsetnosy: + neologix
messages: + msg199580
2013-10-12 12:54:42vstinnercreate