classification
Title: Segmentation fault
Type: crash Stage:
Components: Versions: Python 2.4
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: christian.heimes, mpunkeri
Priority: normal Keywords:

Created on 2008-01-23 06:06 by mpunkeri, last changed 2008-01-23 07:03 by christian.heimes. This issue is now closed.

Files
File name Uploaded Description Edit
backtrace.txt mpunkeri, 2008-01-23 06:06 Backtrace
Messages (3)
msg61558 - (view) Author: Matti Punkeri (mpunkeri) Date: 2008-01-23 06:06
Python seg faults after 20-30 hours. The running Python application is 
a Qt based user interface which handles several SSH threads. Backtrace 
is attached.
msg61559 - (view) Author: Matti Punkeri (mpunkeri) Date: 2008-01-23 06:08
And the program is running on SuSE Linux, 2.6.11.4-20a-default, gcc 
version 3.3.5
msg61560 - (view) Author: Christian Heimes (christian.heimes) * (Python committer) Date: 2008-01-23 07:03
I don't think it's a bug in Python. The crash occurs inside the sip or
qt module, which means it's either a bug in sip, qt or pyqt. Please take
the bug to riverbank computing. Their code might have a memory leak or
reference counting issue.
History
Date User Action Args
2008-01-23 07:03:06christian.heimessetstatus: open -> closed
resolution: not a bug
messages: + msg61560
nosy: + christian.heimes
2008-01-23 06:08:58mpunkerisetmessages: + msg61559
2008-01-23 06:06:45mpunkericreate