classification
Title: PythonLauncher not working correctly on OS X 10.5/Leopad
Type: behavior Stage:
Components: macOS Versions: Python 2.6, Python 2.5
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: ronaldoussoren Nosy List: georg.brandl, mark.dickinson, ronaldoussoren, thelawnmowerman, wordtech
Priority: normal Keywords:

Created on 2008-01-22 14:34 by wordtech, last changed 2008-10-09 10:24 by thelawnmowerman. This issue is now closed.

Messages (5)
msg61506 - (view) Author: Kevin Walzer (wordtech) * Date: 2008-01-22 14:34
On Mac OS X 10.5 (Leopard), using Python 2.5.1, double-clicking on a 
Python script in the Finder does not produce the expected behavior, i.e. 
launch a terminal session and then execute the script. These errors are 
logged in the console:

1/22/08 9:28:56 AM Python Launcher[53692] doscript: Could not activate 
Terminal
 
1/22/08 9:28:56 AM Python Launcher[53692] doscript: AESend(activate): 
error -600
 
1/22/08 9:28:56 AM Python Launcher[53692] Exit status: -600
 
1/22/08 9:28:56 AM com.apple.launchd[118] ([0x0-
0x434434].org.python.PythonLauncher[53692]) Stray process with PGID 
equal to this dead job: PID 53694 PPID 1 Terminal 

I did not observe these behaviors on OS X 10.4.
msg61882 - (view) Author: Mark Dickinson (mark.dickinson) * (Python committer) Date: 2008-01-31 02:06
I can reproduce this in the trunk, on OS X 10.5.1/Intel:  after a

./configure --enable-framework && make && sudo make altinstall

ctrl-clicking on a simple python file on the Desktop and selecting OpenWith -> PythonLauncher fails to run the 
script and gives essentially the same messages in the console:

1/30/08 7:59:31 PM Python Launcher[23508] doscript: Could not activate Terminal
1/30/08 7:59:31 PM Python Launcher[23508] doscript: AESend(activate): error -600
1/30/08 7:59:31 PM Python Launcher[23508] Exit status: -600

Assigning this to Ronald Oussoren since he was the last person to touch PythonLauncher, so probably has a much 
better idea than me of what's going on.

I'm a complete newbie when it comes to AppleEvents and the like, but I'm suspicious of the lines

#define ACTIVATE_CMD 'misc'
#define ACTIVATE_SUITE 'actv'

in Mac/PythonLauncher/doscript.m;  perhaps I'm looking in the wrong place, but I can't find documentation for 
'actv' anywhere.
msg66117 - (view) Author: Ronald Oussoren (ronaldoussoren) * (Python committer) Date: 2008-05-02 21:49
Python Launcher assumes that Terminal.app has a specific creator code, 
that's no longer true in Leopard.

The code in doscript.m was already rather hackish, I've replaced it by
a more modern way to use AppleEvents.

I've committed a fix in rev. 62648 (trunk) and 62649 (2.5 branch). 

A side effect of that patch is that PythonLauncher no longer works on OS 
X 10.2 or earlier, IMHO supporting that release wouldn't be worth the 
trouble.
msg70070 - (view) Author: Georg Brandl (georg.brandl) * (Python committer) Date: 2008-07-20 11:14
No complaints were voiced, so I'm closing this.
msg74564 - (view) Author: The Lawnmower man (thelawnmowerman) Date: 2008-10-09 10:24
Sorry, but I still have the same problem as Kevin Walzer and I can't
understand the solution proposed by Ronald Oussoren. Where is the patch?
How can I install it? What I am supposed to do?

Thank you very much!
History
Date User Action Args
2008-10-09 10:24:15thelawnmowermansetnosy: + thelawnmowerman
messages: + msg74564
2008-07-20 11:14:06georg.brandlsetstatus: pending -> closed
nosy: + georg.brandl
messages: + msg70070
2008-05-02 21:49:26ronaldoussorensetstatus: open -> pending
resolution: fixed
messages: + msg66117
2008-01-31 02:06:42mark.dickinsonsetassignee: ronaldoussoren
messages: + msg61882
nosy: + ronaldoussoren, mark.dickinson
versions: + Python 2.6
2008-01-22 14:34:59wordtechcreate