classification
Title: Make help() enum aware
Type: behavior Stage:
Components: Versions: Python 3.4
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Simplify per-instance control of help() output
View: 19404
Assigned To: Nosy List: barry, eli.bendersky, ethan.furman, ncoghlan, yselivanov
Priority: normal Keywords:

Created on 2013-09-16 00:03 by ethan.furman, last changed 2014-11-01 14:54 by ethan.furman. This issue is now closed.

Messages (4)
msg197845 - (view) Author: Ethan Furman (ethan.furman) * (Python committer) Date: 2013-09-16 00:03
Currently, if help() is called on an Enum member, it displays help for the class.  While this is usually what one wants, it is not for Enums.
msg199128 - (view) Author: Ethan Furman (ethan.furman) * (Python committer) Date: 2013-10-07 03:33
What I'd really like to see is for help to be smart enough to pick up the docstrings from instances if an instance has one.
msg201364 - (view) Author: Nick Coghlan (ncoghlan) * (Python committer) Date: 2013-10-26 14:49
I proposed a possible solution for this in issue 19404
msg230449 - (view) Author: Ethan Furman (ethan.furman) * (Python committer) Date: 2014-11-01 14:54
Closing this as a duplicate of issue19404.
History
Date User Action Args
2014-11-01 14:54:07ethan.furmansetstatus: open -> closed
superseder: Simplify per-instance control of help() output
resolution: duplicate
messages: + msg230449
2014-02-01 00:11:54yselivanovsetnosy: + yselivanov
2013-10-26 14:49:25ncoghlansetnosy: + ncoghlan
messages: + msg201364
2013-10-07 03:33:41ethan.furmansetmessages: + msg199128
2013-09-16 00:03:14ethan.furmancreate