classification
Title: Bug in module netaddr
Type: behavior Stage: resolved
Components: Versions: 3rd party
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: mryding, r.david.murray
Priority: normal Keywords:

Created on 2013-09-06 18:14 by mryding, last changed 2013-09-06 18:50 by r.david.murray. This issue is now closed.

Messages (2)
msg197085 - (view) Author: Mikael Ryding (mryding) Date: 2013-09-06 18:14
I found this in the netaddr module when I was trying to get the CIDR from a number of ip/netmask combinations. The expected cidr in the example below should be: 192.1.0.0/23.

>>> ip = netaddr.IPNetwork("192.1.1.128", "255.255.254.0")
>>> ip.netmask
IPAddress('255.255.255.0')
>>> ip.cidr
IPNetwork('192.1.1.0/24')
msg197088 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2013-09-06 18:50
Netaddr is not an stdlib module.  Please report the bug to the netaddr maintainers.
History
Date User Action Args
2013-09-06 18:50:52r.david.murraysetstatus: open -> closed

versions: + 3rd party, - Python 2.7
nosy: + r.david.murray

messages: + msg197088
resolution: not a bug
stage: resolved
2013-09-06 18:14:05mrydingcreate