classification
Title: help('FILES') finds no documentation
Type: behavior Stage: resolved
Components: Documentation Versions: Python 2.7
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: docs@python Nosy List: Claudiu.Popa, Ramchandra Apte, docs@python, ezio.melotti, georg.brandl, mikehoy, orsenthil, python-dev, serhiy.storchaka, st.sempert@gmail.com, terry.reedy
Priority: normal Keywords: easy, patch

Created on 2013-09-04 04:40 by st.sempert@gmail.com, last changed 2016-01-06 11:57 by orsenthil. This issue is now closed.

Files
File name Uploaded Description Edit
pydoc_files.patch Claudiu.Popa, 2013-09-18 17:15 review
Messages (7)
msg196888 - (view) Author: bussau (st.sempert@gmail.com) Date: 2013-09-04 04:40
Calling for help() about the topic 'FILES' returns 

no documentation found for 'FILES'
------------------------------

Python 2.7.3 (default, Apr 14 2012, 08:58:41) [GCC] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> help('topics')

Here is a list of available topics.  Enter any topic name to get more help.

ASSERTION           DEBUGGING           LITERALS            SEQUENCEMETHODS2
ASSIGNMENT          DELETION            LOOPING             SEQUENCES
ATTRIBUTEMETHODS    DICTIONARIES        MAPPINGMETHODS      SHIFTING
ATTRIBUTES          DICTIONARYLITERALS  MAPPINGS            SLICINGS
AUGMENTEDASSIGNMENT DYNAMICFEATURES     METHODS             SPECIALATTRIBUTES
BACKQUOTES          ELLIPSIS            MODULES             SPECIALIDENTIFIERS
BASICMETHODS        EXCEPTIONS          NAMESPACES          SPECIALMETHODS
BINARY              EXECUTION           NONE                STRINGMETHODS
BITWISE             EXPRESSIONS         NUMBERMETHODS       STRINGS
BOOLEAN             FILES               NUMBERS             SUBSCRIPTS
CALLABLEMETHODS     FLOAT               OBJECTS             TRACEBACKS
CALLS               FORMATTING          OPERATORS           TRUTHVALUE
CLASSES             FRAMEOBJECTS        PACKAGES            TUPLELITERALS
CODEOBJECTS         FRAMES              POWER               TUPLES
COERCIONS           FUNCTIONS           PRECEDENCE          TYPEOBJECTS
COMPARISON          IDENTIFIERS         PRINTING            TYPES
COMPLEX             IMPORTING           PRIVATENAMES        UNARY
CONDITIONAL         INTEGER             RETURNING           UNICODE
CONTEXTMANAGERS     LISTLITERALS        SCOPING             
CONVERSIONS         LISTS               SEQUENCEMETHODS1    

>>> help('FILES')
no documentation found for 'FILES'

--------------------------------------------------------

best regards
stephan
msg196890 - (view) Author: Ramchandra Apte (Ramchandra Apte) * Date: 2013-09-04 05:49
I am able to reproduce on Python 3.3 as well.
msg198027 - (view) Author: PCManticore (Claudiu.Popa) * (Python triager) Date: 2013-09-18 17:15
Hello. The 'File objects' section was removed in Python 3, with this issue http://bugs.python.org/issue7508, but not the topic from pydoc.py. As I understand, there is no point in having this, because there isn't a `file` type anymore.
The attached patched removes the `FILES` topic, which used an undefined reference ('bltin-file-objects', removed in the mentioned issue).
msg219080 - (view) Author: Roundup Robot (python-dev) (Python triager) Date: 2014-05-25 10:05
New changeset 3fa76139c908 by Serhiy Storchaka in branch '3.4':
Issue #18918: Removed non-existing topic from a list of available topics.
http://hg.python.org/cpython/rev/3fa76139c908

New changeset e5bac5b2f38d by Serhiy Storchaka in branch 'default':
Issue #18918: Removed non-existing topic from a list of available topics.
http://hg.python.org/cpython/rev/e5bac5b2f38d
msg219081 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2014-05-25 10:13
Fixed in Python 3. Thanks Claudiu.

But it is not clear why this topic is absent in 2.7.
msg257600 - (view) Author: Roundup Robot (python-dev) (Python triager) Date: 2016-01-06 11:54
New changeset 0792a0ad7f22 by Senthil Kumaran in branch '2.7':
Fix issue18918 : Attach the pydoc documentation for 'FILES' topic.
https://hg.python.org/cpython/rev/0792a0ad7f22
msg257601 - (view) Author: Senthil Kumaran (orsenthil) * (Python committer) Date: 2016-01-06 11:57
The bltin-file-objects was not referenced in pyspecific.py from which this data was generated. Added it and fixed it. 

Verified that it is available in 2.7 now.
History
Date User Action Args
2016-01-06 11:57:41orsenthilsetstatus: open -> closed

nosy: + orsenthil
messages: + msg257601

resolution: fixed
stage: patch review -> resolved
2016-01-06 11:54:26python-devsetmessages: + msg257600
2014-05-25 10:13:33serhiy.storchakasetnosy: + serhiy.storchaka

messages: + msg219081
versions: - Python 3.3, Python 3.4
2014-05-25 10:05:03python-devsetnosy: + python-dev
messages: + msg219080
2013-12-14 01:35:29terry.reedysetnosy: + terry.reedy
2013-10-19 04:44:20ezio.melottisetnosy: + georg.brandl

stage: needs patch -> patch review
2013-09-18 17:15:43Claudiu.Popasetfiles: + pydoc_files.patch

nosy: + Claudiu.Popa
messages: + msg198027

keywords: + patch
2013-09-18 02:25:31mikehoysetnosy: + mikehoy
2013-09-07 12:28:35ezio.melottisetkeywords: + easy
nosy: + ezio.melotti

stage: needs patch
2013-09-04 05:49:15Ramchandra Aptesetversions: + Python 3.3, Python 3.4
nosy: + Ramchandra Apte

messages: + msg196890

components: - Interpreter Core
2013-09-04 04:40:20st.sempert@gmail.comcreate