classification
Title: New regex module degrades re performance
Type: performance Stage: resolved
Components: Regular Expressions Versions: Python 3.1, Python 3.2, Python 3.3, Python 3.4, Python 2.7, Python 2.6
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: Tal.Weiss, ezio.melotti, mrabarnett, pitrou, serhiy.storchaka, vstinner
Priority: normal Keywords:

Created on 2013-08-25 17:26 by Tal.Weiss, last changed 2013-08-25 19:05 by ned.deily. This issue is now closed.

Files
File name Uploaded Description Edit
play_regex.py Tal.Weiss, 2013-08-25 17:26 Timeit repeat regex vs re compare
Messages (2)
msg196153 - (view) Author: Tal Weiss (Tal.Weiss) Date: 2013-08-25 17:26
All tests I ran comparing timing of the new regex module relative to the old re module showed significant slower performance.
I'm attaching test code with regular expressions from our production server.
Tested on Python 2.7, 64 bit Linux + 64 bit Windows 7.
regex #0 match success = 0.16530585289 seconds
re    #0 match success = 0.0977821350098 seconds
regex #0 match failure = 0.460994958878 seconds
re    #0 match failure = 0.249558925629 seconds
regex #1 match success = 0.0802597999573 seconds
re    #1 match success = 0.0348429679871 seconds
regex #1 match failure = 0.224385023117 seconds
re    #1 match failure = 0.104065895081 seconds
regex #2 match success = 0.0307199954987 seconds
re    #2 match success = 0.0200390815735 seconds
regex #2 match failure = 0.0253899097443 seconds
re    #2 match failure = 0.0161480903625 seconds
msg196159 - (view) Author: Matthew Barnett (mrabarnett) * (Python triager) Date: 2013-08-25 18:49
The 'regex' module is not part of the CPython distribution, so it's not covered by this tracker.
History
Date User Action Args
2013-08-25 19:05:37ned.deilysetstatus: open -> closed
resolution: not a bug
stage: resolved
2013-08-25 18:49:04mrabarnettsetmessages: + msg196159
2013-08-25 17:26:23Tal.Weisscreate