classification
Title: To change the doc of html/faq/gui.html
Type: enhancement Stage: resolved
Components: Documentation Versions: Python 3.4, Python 3.5, Python 2.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: docs@python Nosy List: BreamoreBoy, aleax, docs@python, eric.araujo, ezio.melotti, georg.brandl, madan.ram, r.david.murray
Priority: normal Keywords: patch

Created on 2013-08-10 18:01 by madan.ram, last changed 2014-06-19 16:25 by r.david.murray. This issue is now closed.

Files
File name Uploaded Description Edit
mywork.patch madan.ram, 2013-08-10 18:29 review
Messages (4)
msg194824 - (view) Author: madan ram (madan.ram) Date: 2013-08-10 18:01
"Qt 4.5 upwards is licensed under the LGPL license; also, commercial licenses are available from Nokia."

Since new version of Qt 5 is realsed and Licenced under Digia.

So i am fixing this issue .

i am going to write it as 

PyQt5 is licensed on all platforms under a commercial license and the GPL v3. Your PyQt5 license must be compatible with your Qt license.
If you use the GPL version then your own code must also use a compatible license.

Note:-PyQt5, unlike Qt, is not available under the LGPL.

You can purchase a commercial PyQt5 license here.
msg194832 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2013-08-10 20:22
It seems to me (having checked) that the current language is correct.  The fact that PyQt5 is available under the GPL isn't really relevant to the FAQ as it currently exists (it doesn't mention the GPL anywhere else).  Keep in mind that Python's license is non-GPL.  Adding GPL-licensed product information would be a whole different level of change, I think.
msg195078 - (view) Author: Éric Araujo (eric.araujo) * (Python committer) Date: 2013-08-13 15:03
Also, the GPLs allows commercial usage, so using “LGPL” and “commercial” to mean two different licensing cases is not quite right.
msg221001 - (view) Author: Mark Lawrence (BreamoreBoy) * Date: 2014-06-19 16:04
It looks as if there's nothing to be done here, is that correct?
History
Date User Action Args
2014-06-19 16:25:16r.david.murraysetstatus: open -> closed
resolution: not a bug
stage: resolved
2014-06-19 16:04:58BreamoreBoysetnosy: + BreamoreBoy

messages: + msg221001
versions: - Python 3.1, Python 3.2, Python 3.3
2013-08-13 15:03:58eric.araujosetmessages: + msg195078
2013-08-10 20:22:37r.david.murraysetnosy: + r.david.murray
messages: + msg194832
2013-08-10 18:34:09madan.ramsetnosy: + aleax, georg.brandl, ezio.melotti, eric.araujo
2013-08-10 18:29:30madan.ramsetfiles: + mywork.patch
keywords: + patch
2013-08-10 18:29:13madan.ramsetfiles: - gui.rst
2013-08-10 18:01:27madan.ramsettype: enhancement
2013-08-10 18:01:15madan.ramcreate