classification
Title: In unittest.TestCase.longMessage doc remove a redundant sentence
Type: enhancement Stage: resolved
Components: Documentation Versions: Python 3.3, Python 3.4
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: docs@python Nosy List: docs@python, ezio.melotti, py.user, r.david.murray
Priority: normal Keywords: patch

Created on 2013-08-09 15:58 by py.user, last changed 2013-08-10 16:01 by ezio.melotti. This issue is now closed.

Files
File name Uploaded Description Edit
issue18696.diff py.user, 2013-08-09 15:58 review
Messages (3)
msg194748 - (view) Author: py.user (py.user) * Date: 2013-08-09 15:58
http://docs.python.org/3/library/unittest.html#unittest.TestCase.longMessage
"If set to True then any explicit failure message you pass in to the assert methods will be appended to the end of the normal failure message. The normal messages contain useful information about the objects involved, for example the message from assertEqual shows you the repr of the two unequal objects. Setting this attribute to True allows you to have a custom error message in addition to the normal one."

the last sentence duplicates the first one
msg194750 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2013-08-09 16:05
I think the text is OK as it stands.  The first sentence is a technical description of the result of setting the attribute, the last sentence is a conceptual discussion of why you would want to set the attribute.
msg194813 - (view) Author: Ezio Melotti (ezio.melotti) * (Python committer) Date: 2013-08-10 16:01
Agreed, closing.
History
Date User Action Args
2013-08-10 16:01:48ezio.melottisetstatus: open -> closed

nosy: + ezio.melotti
messages: + msg194813

resolution: not a bug
stage: resolved
2013-08-09 16:05:48r.david.murraysetnosy: + r.david.murray
messages: + msg194750
2013-08-09 15:58:07py.usercreate