classification
Title: Document undocumented Unicode object API
Type: behavior Stage: resolved
Components: Documentation, Unicode Versions: Python 3.4, Python 3.5
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Document PyUnicode_* API
View: 1944
Assigned To: docs@python Nosy List: berker.peksag, docs@python, ezio.melotti, r.david.murray, serhiy.storchaka, vstinner
Priority: normal Keywords:

Created on 2013-08-08 19:12 by serhiy.storchaka, last changed 2016-04-30 18:41 by berker.peksag. This issue is now closed.

Messages (3)
msg194705 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2013-08-08 19:12
Include/unicodeobject.h contains followed names which are declared as public but are not documented in Doc/c-api/unicode.rst.

PyUnicodeIter_Type
Py_UNICODE_REPLACEMENT_CHARACTER
PyUnicode_Resize
PyUnicode_InternImmortal
PyUnicode_CHECK_INTERNED
PyUnicode_FromOrdinal
PyUnicode_GetDefaultEncoding
PyUnicode_AsDecodedObject
PyUnicode_AsDecodedUnicode
PyUnicode_AsEncodedObject
PyUnicode_AsEncodedUnicode
PyUnicode_BuildEncodingMap
PyUnicode_DecodeCodePageStateful
PyUnicode_Append
PyUnicode_AppendAndDel
PyUnicode_Partition
PyUnicode_RPartition
PyUnicode_RSplit
PyUnicode_IsIdentifier
_PyUnicode_FromId
_PyUnicode_ClearStaticStrings

They should be either documented or declared as private.

PyUnicode_AsEncodedObject only mentioned in Doc/whatsnew/3.3.rst as recomended replacement of PyUnicode_Encode.
msg194756 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2013-08-09 18:50
It will be good first resolve issue18697.
msg264572 - (view) Author: Berker Peksag (berker.peksag) * (Python committer) Date: 2016-04-30 18:40
This is a duplicate of issue 1944.
History
Date User Action Args
2016-04-30 18:41:21berker.peksagsetsuperseder: Document PyUnicode_* API
2016-04-30 18:40:02berker.peksagsetstatus: open -> closed

nosy: + berker.peksag
messages: + msg264572

resolution: duplicate
stage: needs patch -> resolved
2014-11-17 21:20:52serhiy.storchakasetversions: + Python 3.5, - Python 3.3
2013-12-24 19:45:59serhiy.storchakasetnosy: + r.david.murray
2013-08-09 18:50:42serhiy.storchakasetmessages: + msg194756
2013-08-09 10:15:21pitrousetnosy: + vstinner
2013-08-08 19:12:46serhiy.storchakacreate