classification
Title: Daemon Threads can seg fault
Type: Stage: resolved
Components: Documentation Versions: Python 2.7
process
Status: closed Resolution: wont fix
Dependencies: Superseder:
Assigned To: docs@python Nosy List: docs@python, guettli, vstinner
Priority: normal Keywords:

Created on 2013-08-07 09:23 by guettli, last changed 2019-04-27 10:42 by asvetlov. This issue is now closed.

Messages (3)
msg194601 - (view) Author: Thomas Guettler (guettli) Date: 2013-08-07 09:23
This is a documentation bug: Since #1856  is not solved for Python2, it needs to be documented.

Daemon Threads on Python2 can seg fault.

Work arounds: http://stackoverflow.com/questions/18098475/detect-interpreter-shut-down-in-daemon-thread
msg227973 - (view) Author: Mark Lawrence (BreamoreBoy) * Date: 2014-09-30 18:49
@Thomas can you provide a patch for this issue?
msg227983 - (view) Author: Thomas Guettler (guettli) Date: 2014-09-30 19:26
What kind of patch do you want? Documentation patch or fixing the bug in the interpreter?

I am not a native speaker, that's why I avoid documentation patches.

For me, the issue is solved. It is documented in stackoverflow and here.

Since Python2 will be gone sooner or later, I don't want to invest hours into fixing this at interpreter level.

Should I close the issue?
History
Date User Action Args
2019-04-27 10:42:32asvetlovsetstatus: open -> closed
resolution: wont fix
stage: resolved
2019-04-26 20:41:08BreamoreBoysetnosy: - BreamoreBoy
2014-09-30 19:27:00guettlisetmessages: + msg227983
2014-09-30 18:49:23BreamoreBoysetnosy: + BreamoreBoy

messages: + msg227973
versions: - Python 2.6
2013-08-09 20:17:31vstinnersetnosy: + vstinner
2013-08-07 09:23:16guettlicreate