classification
Title: Mercurial CPython log ticket link is broken
Type: Stage: resolved
Components: Versions:
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: ezio.melotti, ned.deily, vajrasky
Priority: normal Keywords:

Created on 2013-08-05 01:48 by vajrasky, last changed 2013-08-05 07:38 by ned.deily. This issue is now closed.

Messages (6)
msg194444 - (view) Author: Vajrasky Kok (vajrasky) * Date: 2013-08-05 01:48
Go to http://hg.python.org/cpython.

All ticket links (number preceded by #), such as #18567 refer to bugs in jython.

For example:
5 hours ago 	R David Murray 	Merge: #18657: remove duplicate entries from Misc/ACKS.default tip
5 hours ago 	R David Murray 	#18657: remove duplicate entries from Misc/ACKS.3.3

The "Merge" link refers to correct place. But "#18657" goes to http://bugs.jython.org/issue18657.

It happens to *all ticket links*.
msg194446 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2013-08-05 05:12
Sorry, I'm not seeing this behavior.  Is it still happening for you?
msg194451 - (view) Author: Vajrasky Kok (vajrasky) * Date: 2013-08-05 06:17
Okay, it looks like it has been fixed. The format has changed as well.

Previously:
5 hours ago 	R David Murray 	Merge: #18657: remove duplicate entries from Misc/ACKS.default tip
5 hours ago 	R David Murray 	#18657: remove duplicate entries from Misc/ACKS.3.3

Now:
10 hours ago 	R David Murray 	Merge: #18657: remove duplicate entries from Misc/ACKS. [#18657] default
10 hours ago 	R David Murray 	#18657: remove duplicate entries from Misc/ACKS. [#18657] 3.3

Now we have separate link to ticket (inside the bracket) at the end of commit message, whereas previously it was inside the commit message.

I guess we can close this ticket as fixed.
msg194455 - (view) Author: Vajrasky Kok (vajrasky) * Date: 2013-08-05 07:23
Wait, something weird is happening in CPython commits log website, http://hg.python.org/cpython .

These are the latest four commits.

age 	author 	description
45 hours ago 	Jason R. Coombs 	Issue 18532: Added tests and documentation to formally specify the .name attribute on hashlib objects.default tip
105 minutes ago 	Raymond Hettinger 	Silence compiler warning for unused declaration.2.7
11 hours ago 	R David Murray 	Merge: #18657: remove duplicate entries from Misc/ACKS. [#18657]
11 hours ago 	R David Murray 	#18657: remove duplicate entries from Misc/ACKS. [#18657]3.3

The "age" column is screwed up. 11 hours ago goes to 105 minutes ago then goes back to 45 hours ago.
msg194456 - (view) Author: Ezio Melotti (ezio.melotti) * (Python committer) Date: 2013-08-05 07:30
This is a separate issue though, isn't it?
Have you tried to ctrl+f5 the page?

(Also this is probably something that should be reported to the Mercurial bug tracker, since -- unlike the issue links -- is not something we modified.)
msg194458 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2013-08-05 07:38
While it looks unusual, the commit list is fine.  It reflects what you see currently in a "hg log".  What happened is that someone imported an older local change set or something similar.  It's not always easy to tell from the log.
History
Date User Action Args
2013-08-05 07:38:11ned.deilysetstatus: open -> closed
resolution: not a bug
messages: + msg194458

stage: resolved
2013-08-05 07:30:25ezio.melottisetnosy: + ezio.melotti
messages: + msg194456
2013-08-05 07:23:38vajraskysetmessages: + msg194455
2013-08-05 06:17:49vajraskysetmessages: + msg194451
2013-08-05 05:12:36ned.deilysetnosy: + ned.deily
messages: + msg194446
2013-08-05 01:48:24vajraskycreate