classification
Title: intermittent test_pydoc failure on 3.4.0a1
Type: Stage: resolved
Components: Tests Versions: Python 3.4
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: Esa.Peuha, ned.deily
Priority: normal Keywords:

Created on 2013-08-03 22:06 by ned.deily, last changed 2014-04-14 18:57 by ned.deily. This issue is now closed.

Messages (4)
msg194309 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2013-08-03 22:06
Testing the 3.4.0a1 OS X 10.6 installer on OS X 10.8, I've now seen test_pydoc fail twice when the tests are run in order but then passing when the test is automatically rerun.  I've not seen this failure previously.

/usr/local/bin/python3.4 -m test -w -uall,-largefile== CPython 3.4.0a1 (v3.4.0a1:46535f65e7f3, Aug 3 2013, 14:03:34) [GCC 4.2.1 (Apple Inc. build 5666) (dot 3)]
==   Darwin-12.5.0-x86_64-i386-32bit little-endian
==   /private/var/folders/42/hjgpmmxd2wbcrzh4r9vsk_6h0000gr/T/test_python_3742
Testing with flags: sys.flags(debug=0, inspect=0, interactive=0, optimize=0, dont_write_bytecode=0, no_user_site=0, no_site=0, ignore_environment=0, verbose=0, bytes_warning=0, quiet=0, hash_randomization=1)
[  1/376] test_grammar
...
[250/376] test_pyclbr
[251/376] test_pydoc
test test_pydoc failed -- Traceback (most recent call last):
  File "/Library/Frameworks/Python.framework/Versions/3.4/lib/python3.4/test/test_pydoc.py", line 624, in test_url_requests
    self.assertEqual(result, title, text)
AssertionError: 'Pydoc: Error - ' != 'Pydoc: Index of Modules'
- Pydoc: Error -
+ Pydoc: Index of Modules
 : <!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<html><head><title>Pydoc: Error - </title>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
<link rel="stylesheet" type="text/css" href="pydoc_data/_pydoc.css"></head><body bgcolor="#f0f0f8">
            <div style='float:left'>
                Python 3.4.0a1 [v3.4.0a1:46535f65e7f3, GCC 4.2.1 (Apple Inc. build 5666) (dot 3)]<br>Darwin-12.5.0
            </div>
            <div style='float:right'>
                <div style='text-align:center'>
                  <a href="index.html">Module Index</a>
                  : <a href="topics.html">Topics</a>
                  : <a href="keywords.html">Keywords</a>
                </div>
                <div>
                    <form action="get" style='display:inline;'>
                      <input type=text name=key size=15>
                      <input type=submit value="Get">
                    </form>&nbsp;
                    <form action="search" style='display:inline;'>
                      <input type=text name=key size=15>
                      <input type=submit value="Search">
                    </form>
                </div>
            </div>
            <div style="clear:both;padding-top:.5em;">
<table width="100%" cellspacing=0 cellpadding=2 border=0 summary="heading">
<tr bgcolor="#7799ee">
<td valign=bottom>&nbsp;<br>
<font color="#ffffff" face="helvetica, arial">&nbsp;<br><big><big><strong>Error</strong></big></big></font></td
><td align=right valign=bottom
><font color="#ffffff" face="helvetica, arial">&nbsp;</font></td></tr></table>
    <p>
<table width="100%" cellspacing=0 cellpadding=2 border=0 summary="section">
<tr bgcolor="#bb0000">
<td colspan=3 valign=bottom>&nbsp;<br>
<font color="#ffffff" face="helvetica, arial"><big><strong></strong></big></font></td></tr>

<tr><td bgcolor="#bb0000"><tt>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</tt></td><td>&nbsp;</td>
<td width="100%">KeyError: '/Users/pyi/Library/Python/3.4/lib/python/site-packages/setuptools-0.9.8-py3.4.egg'
</td></tr></table></div>
</body></html>

[252/376/1] test_pyexpat
...
Re-running failed tests in verbose mode
Re-running test 'test_pydoc' in verbose mode
...
test_url_requests (test.test_pydoc.PydocUrlHandlerTest) ... ok
test_keywords (test.test_pydoc.TestHelper) ... ok

----------------------------------------------------------------------
Ran 25 tests in 2.253s

OK
msg200563 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2013-10-20 10:43
Still intermittently failing on 3.4.0a4 when running the entire test suite.
msg200723 - (view) Author: Esa Peuha (Esa.Peuha) Date: 2013-10-21 08:53
The problem seems to be /Users/pyi/Library/Python/3.4/lib/python/site-packages/setuptools-0.9.8-py3.4.egg according to the error page. What is that file? The fact that the second run of the test succeeds implies that it could be a temporary file which is no longer present when the test is run again.
msg216170 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2014-04-14 18:57
Thanks for noticing the errant setuptools egg in the --user site-packages location. That should not have been there.
History
Date User Action Args
2014-04-14 18:57:20ned.deilysetstatus: open -> closed
resolution: not a bug
messages: + msg216170

stage: resolved
2013-10-21 08:53:33Esa.Peuhasetnosy: + Esa.Peuha
messages: + msg200723
2013-10-20 10:43:42ned.deilysetmessages: + msg200563
2013-08-03 22:06:03ned.deilycreate