classification
Title: test_signal failure under Windows
Type: behavior Stage: needs patch
Components: Tests, Windows Versions: Python 3.4
process
Status: closed Resolution: duplicate
Dependencies: Superseder: test_signal.test_issue9324() fails on buildbot AMD64 Windows7 SP1 3.x
View: 18396
Assigned To: vstinner Nosy List: brian.curtin, larry, pitrou, vstinner
Priority: release blocker Keywords:

Created on 2013-07-21 19:35 by pitrou, last changed 2013-07-22 19:15 by vstinner. This issue is now closed.

Messages (2)
msg193464 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2013-07-21 19:35
c31bec42e4112a49c192a16f271faffd5a44b83d (by Victor) seems to be the culprit.

See http://buildbot.python.org/all/builders/AMD64%20Windows7%20SP1%203.x/builds/2188



======================================================================
ERROR: test_issue9324 (test.test_signal.WindowsSignalTests)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "C:\buildbot.python.org\3.x.kloth-win64\build\lib\test\test_signal.py", line 213, in test_issue9324
    signal.signal(sig, signal.signal(sig, handler))
TypeError: signal handler must be signal.SIG_IGN, signal.SIG_DFL, or a callable object
msg193469 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2013-07-21 21:34
This issue is a duplicate of #18396.
Le 21 juil. 2013 21:35, "Antoine Pitrou" <report@bugs.python.org> a écrit :

>
> New submission from Antoine Pitrou:
>
> c31bec42e4112a49c192a16f271faffd5a44b83d (by Victor) seems to be the
> culprit.
>
> See
> http://buildbot.python.org/all/builders/AMD64%20Windows7%20SP1%203.x/builds/2188
>
>
>
> ======================================================================
> ERROR: test_issue9324 (test.test_signal.WindowsSignalTests)
> ----------------------------------------------------------------------
> Traceback (most recent call last):
>   File "C:\buildbot.python.org\3.x.kloth-win64\build\lib\test\test_signal.py",
> line 213, in test_issue9324
>     signal.signal(sig, signal.signal(sig, handler))
> TypeError: signal handler must be signal.SIG_IGN, signal.SIG_DFL, or a
> callable object
>
> ----------
> assignee: haypo
> components: Tests, Windows
> messages: 193464
> nosy: brian.curtin, haypo, larry, pitrou
> priority: release blocker
> severity: normal
> stage: needs patch
> status: open
> title: test_signal failure under Windows
> type: behavior
> versions: Python 3.4
>
> _______________________________________
> Python tracker <report@bugs.python.org>
> <http://bugs.python.org/issue18523>
> _______________________________________
>
History
Date User Action Args
2013-07-22 19:15:45vstinnersetstatus: open -> closed
superseder: test_signal.test_issue9324() fails on buildbot AMD64 Windows7 SP1 3.x
resolution: duplicate
2013-07-21 21:34:43vstinnersetmessages: + msg193469
2013-07-21 19:35:41pitroucreate