classification
Title: Won't install. Keeps telling me DLL is missing.
Type: crash Stage:
Components: Installation Versions: Python 2.7
process
Status: closed Resolution: works for me
Dependencies: Superseder:
Assigned To: Nosy List: daleastar, loewis, r.david.murray, terry.reedy
Priority: normal Keywords:

Created on 2013-07-04 15:01 by daleastar, last changed 2013-07-11 00:24 by terry.reedy. This issue is now closed.

Files
File name Uploaded Description Edit
python.log daleastar, 2013-07-06 20:50
Messages (16)
msg192294 - (view) Author: Dale Smith (daleastar) Date: 2013-07-04 15:01
When I click install -> run, it tells me a DLL is missing and to contact my vendor (Windows 7 Home Premium).

This is the only installation that does this. I cannot find an answer anywhere and all other installations work fine.  What could be causing this?  Which DLL is specific only to this installation that Microsoft does not have an answer to?  Thank you.
msg192315 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2013-07-04 20:17
Exactly which installer are you trying to run and where did you download it from?
msg192317 - (view) Author: Dale Smith (daleastar) Date: 2013-07-04 20:54
http://www.python.org/ftp/python/2.7.5/python-2.7.5.msi

That is the URL I downloaded from and the installer.

Thank you,

Dale

On 7/4/2013 4:17 PM, R. David Murray wrote:
> R. David Murray added the comment:
>
> Exactly which installer are you trying to run and where did you download it from?
>
> ----------
> nosy: +r.david.murray
>
> _______________________________________
> Python tracker <report@bugs.python.org>
> <http://bugs.python.org/issue18360>
> _______________________________________
msg192333 - (view) Author: Dale Smith (daleastar) Date: 2013-07-05 15:32
Was that all the correct information? Do you need more... i.e. about my 
computer etc?

On 7/4/2013 4:17 PM, R. David Murray wrote:
> R. David Murray added the comment:
>
> Exactly which installer are you trying to run and where did you download it from?
>
> ----------
> nosy: +r.david.murray
>
> _______________________________________
> Python tracker <report@bugs.python.org>
> <http://bugs.python.org/issue18360>
> _______________________________________
msg192350 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2013-07-05 19:39
When responding by email, *please* delete the quote, except perhaps for a line or two if really needed. The email signature is *never* needed and *always* noise.

I install on Windows with no problem. I presume you too see 'Install' by right-clicking on the .msi file in Explorer or elsewhere. Does the message tell you *what* .dll is missing? I suspect that it is one of the Windows dlls that are needed for msi installs and not included in the .msi.
msg192474 - (view) Author: Dale Smith (daleastar) Date: 2013-07-06 17:34
I do see install and it tries to install.  When I click "run" and go to 
the install menu, I select for "All users" and next and the generic "a 
dll is missing" message pops up.  I'll explore this more.   I do not 
have problems installing anything else.  Thank you!
msg192477 - (view) Author: Dale Smith (daleastar) Date: 2013-07-06 18:11
I tried everything that is available to "repair" my Windows 7 installer 
(unregistered/restarted the service etc).  Everything installs fine 
except this installer.
msg192478 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2013-07-06 18:29
Thank you for the snips.

Have you installed other applications that use a .msi installer (many do not).
Have you tried another Python installer? For instance, change .5 to .3 in your link.
Are you using a 64-bit installer on 32-bit Windows? It seems not as the link you gave *is* to the (default) 32-bit version.

I searched the 2.7 repository for "dll is missing". No hits. So if you quoted accurately, that too-generic text is not coming from Python.

Martin, any ideas on this install problem?
msg192480 - (view) Author: Dale Smith (daleastar) Date: 2013-07-06 18:44
I do not know when but there is a version that seems to be installed.  
It's in my programs folder.  I opened the python shell and it says it is 
Python 2.7.3 (default, Apr 10 2012, 23:31:26) [MSC v.1500 32 bit 
(Intel)] on win32

It still does not explain the dll error message.  I do assume its 
windows (of course).
msg192483 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2013-07-06 19:36
Please open a cmd.exe shell, change to the directory containing the MSI file, and run

msiexec /i python-2.7.5.msi /l*v python.log

Then attach the resulting python.log file. If it is too large, compress it to a zip file.
msg192486 - (view) Author: Dale Smith (daleastar) Date: 2013-07-06 20:50
python log attached. Thank you.
msg192607 - (view) Author: Dale Smith (daleastar) Date: 2013-07-08 03:11
Has anyone figured out what is causing this failure from my windows 7?  
Thank you.
msg192655 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2013-07-08 14:40
You will have to wait until Martin can respond, but the log says failure occurred with
C:\Users\astar\AppData\Local\Temp\MSIA812.tmp entry: _CheckDir@4
Description from web:
   Driver Install Frameworks for Applications library module
This appears to part of the unpacked download. Have you redownloaded?
msg192656 - (view) Author: Dale Smith (daleastar) Date: 2013-07-08 14:54
I have redownloaded.  Still getting the same message.  Thank you.
msg192798 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2013-07-10 12:09
I'm pretty sure the problem is the one reported in

http://superuser.com/questions/478631/dll-could-not-be-run-for-msi-installers

The solution/work-around is to give full access to Everyone in the Temp folder.

Please report whether this works.
msg192838 - (view) Author: Dale Smith (daleastar) Date: 2013-07-10 21:32
I got it!  None of these alone actually worked.  But it lead me to get 
it to work.  I did several solutions at once.  The three in combination 
that worked were getting this: 
http://www.howtogeek.com/howto/windows-vista/add-take-ownership-to-explorer-right-click-menu-in-vista 
<http://www.howtogeek.com/howto/windows-vista/add-take-ownership-to-explorer-right-click-menu-in-vista/>

then I disabled my antivirus and User Account Control in windows 7. I'll 
bet it was just disabling the UAC that did it though.  I will find out 
later.  I need to get back to class now that I have what I need.  Thank 
you so much.  If you do need more info or help, please feel free to ask!
<http://www.howtogeek.com/howto/windows-vista/add-take-ownership-to-explorer-right-click-menu-in-vista/>
History
Date User Action Args
2013-07-11 00:24:15terry.reedysetstatus: open -> closed
resolution: works for me
2013-07-10 21:32:05daleastarsetmessages: + msg192838
2013-07-10 12:09:04loewissetmessages: + msg192798
2013-07-08 14:54:51daleastarsetmessages: + msg192656
2013-07-08 14:40:41terry.reedysetmessages: + msg192655
2013-07-08 03:11:37daleastarsetmessages: + msg192607
2013-07-06 20:50:57daleastarsetfiles: + python.log

messages: + msg192486
2013-07-06 19:36:47loewissetmessages: + msg192483
2013-07-06 18:44:22daleastarsetmessages: + msg192480
2013-07-06 18:29:18terry.reedysetnosy: + loewis
messages: + msg192478
2013-07-06 18:11:28daleastarsetmessages: + msg192477
2013-07-06 17:34:33daleastarsetmessages: + msg192474
2013-07-05 19:39:16terry.reedysetnosy: + terry.reedy
messages: + msg192350
2013-07-05 15:32:01daleastarsetmessages: + msg192333
2013-07-04 20:54:14daleastarsetmessages: + msg192317
2013-07-04 20:17:38r.david.murraysetnosy: + r.david.murray
messages: + msg192315
2013-07-04 15:01:24daleastarcreate