classification
Title: enhancements zlib.compress/decompress to accept Py_buffer
Type: enhancement Stage: resolved
Components: Extension Modules Versions: Python 2.7
process
Status: closed Resolution: rejected
Dependencies: Superseder:
Assigned To: Nosy List: jamercee, jcea
Priority: normal Keywords: patch

Created on 2013-07-01 15:52 by jamercee, last changed 2013-07-04 02:23 by jcea. This issue is now closed.

Files
File name Uploaded Description Edit
zlibmodule.c.patch jamercee, 2013-07-01 15:52 zlibmodule.c patch review
Messages (2)
msg192135 - (view) Author: Jim Carroll (jamercee) * Date: 2013-07-01 15:52
We were looking to squeak maximum performance out of zlib.compress. We noticed in py3k, zlib.compress already accepts Py_buffer’s, but in 2.x, compress required strings.  

We’ve modified the compress (and decompress for orthogonal completeness), see the attached patch.
msg192266 - (view) Author: Jesús Cea Avión (jcea) * (Python committer) Date: 2013-07-04 02:23
This is not a bugfix, but a new feature, and 2.7 is closed for new features. Sorry.

If you think the closing of this bug report is a mistake, reopen with your argument.
History
Date User Action Args
2013-07-04 02:23:30jceasetstatus: open -> closed

nosy: + jcea
messages: + msg192266

resolution: rejected
stage: resolved
2013-07-01 15:52:42jamerceecreate