classification
Title: Doc make html: KeyError: 'howto/advocacy'
Type: behavior Stage: resolved
Components: Documentation Versions: Python 3.3, Python 3.4, Python 2.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: docs@python Nosy List: docs@python, eric.araujo, ezio.melotti, georg.brandl, r.david.murray, terry.reedy
Priority: normal Keywords:

Created on 2013-06-22 18:44 by terry.reedy, last changed 2013-06-22 21:00 by r.david.murray. This issue is now closed.

Files
File name Uploaded Description Edit
sphinx-err-xoinkq.log terry.reedy, 2013-06-22 18:44
Messages (5)
msg191654 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2013-06-22 18:44
Win 7, make html, 2.7 and 3.3.

writing output... [ 20%] howto/advocacy

Exception occurred:
  File "F:\Python\dev\py33\Doc\tools\sphinx\environment.py", line 1063, in get_toc_for
    toc = self.tocs[docname].deepcopy()
KeyError: 'howto/advocacy'

and process stops. Since update did not change the sphinx install that worked when I last tried this (April), I presume error is in our sources rather than Sphinx.
msg191656 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2013-06-22 18:51
I just did a clean doc build on 2.7 (on linux) on 2.7 head without error.  Maybe you need to do a 'make clean' and rebuild?  Our Makefile ought to have a target that just throws away the build dir, instead of throwing away the checked out software as well, but it doesn't.  So instead of make clean you might want to try just deleting the build dir and rebuilding first.
msg191657 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2013-06-22 18:53
Oh, right, the advocacy howto was deleted recently.  So it is almost certainly your stale pickles in the build dir that are the issue.
msg191671 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2013-06-22 20:34
Nuking build worked. So did, with less re-work, deleting the advocacy doctree and html files ;-). Too bad this is not somehow automated.
msg191674 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2013-06-22 21:00
Automating it could be a sphinx enhancement request.  Or maybe a bug report.
History
Date User Action Args
2013-06-22 21:00:02r.david.murraysetmessages: + msg191674
2013-06-22 20:34:42terry.reedysetstatus: pending -> closed

messages: + msg191671
2013-06-22 18:53:06r.david.murraysetstatus: open -> pending
resolution: not a bug
messages: + msg191657

stage: resolved
2013-06-22 18:51:56r.david.murraysetnosy: + r.david.murray
messages: + msg191656
2013-06-22 18:44:34terry.reedycreate