classification
Title: Accessing attr dict at definition time of a class from a metaclass results in changed type.
Type: Stage:
Components: Interpreter Core Versions: Python 3.2
process
Status: closed Resolution: out of date
Dependencies: Superseder:
Assigned To: Nosy List: archardlias, georg.brandl
Priority: normal Keywords:

Created on 2013-06-18 10:21 by archardlias, last changed 2013-10-14 14:27 by georg.brandl. This issue is now closed.

Files
File name Uploaded Description Edit
bugreport_cpython3.2.3.py archardlias, 2013-06-18 10:21 Failed Test Case
Messages (2)
msg191394 - (view) Author: Archard Lias (archardlias) Date: 2013-06-18 10:21
Accessing (just iterating or accessing in any way) the dict_proxy to the attribute dictionary in the `MessageMeta` metaclass, results in a change of "type" in any metaclass inheriting class definitions.

Reproducible in CPython versions (tested so far):
3.2.2
3.2.3

Works as of, or at least behaves as I subjectively intended to use it (only version tested)
3.3.2
msg199896 - (view) Author: Georg Brandl (georg.brandl) * (Python committer) Date: 2013-10-14 14:27
Only affects 3.2, so this won't be fixed anymore.
History
Date User Action Args
2013-10-14 14:27:51georg.brandlsetstatus: open -> closed

nosy: + georg.brandl
messages: + msg199896

resolution: out of date
2013-06-18 10:21:45archardliascreate