classification
Title: Problem creating extension in python3.3 with mingw32
Type: Stage:
Components: Distutils, Extension Modules Versions: Python 3.3
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: eric.araujo Nosy List: adityaatluri, amaury.forgeotdarc, eric.araujo, tarek
Priority: normal Keywords:

Created on 2013-06-14 09:43 by adityaatluri, last changed 2013-06-14 09:56 by amaury.forgeotdarc. This issue is now closed.

Files
File name Uploaded Description Edit
Build-Bug.zip adityaatluri, 2013-06-14 09:43
Messages (2)
msg191113 - (view) Author: Aditya Atluri (adityaatluri) Date: 2013-06-14 09:43
I am trying to build c extensions in windows using mingw32. The file hello.c works fine with 2.7 but, errors are poping up in 3.3.
Attachments:
[1] log.txt : The errors
[2] hello.c : The C file
[3] setup.py: The setup file

The command I used in cmd is, "python setup.py build -c mingw32"
msg191114 - (view) Author: Amaury Forgeot d'Arc (amaury.forgeotdarc) * (Python committer) Date: 2013-06-14 09:56
Python3 has a new API to create modules: PyModule_Create() and PyModuleDef.

See also:
http://docs.python.org/3/howto/cporting.html?highlight=pymodule_create#module-initialization-and-state
History
Date User Action Args
2013-06-14 09:56:00amaury.forgeotdarcsetstatus: open -> closed

nosy: + amaury.forgeotdarc
messages: + msg191114

resolution: not a bug
2013-06-14 09:43:21adityaatluricreate