classification
Title: Python 2.7.5 installation broken on OpenSuse 12.2
Type: behavior Stage: resolved
Components: Build Versions: Python 2.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Problems with /usr/lib64 builds.
View: 1294959
Assigned To: Nosy List: Andreas.Jung, Tom.Gross, ned.deily
Priority: normal Keywords:

Created on 2013-05-29 06:25 by Andreas.Jung, last changed 2020-02-12 01:21 by vstinner. This issue is now closed.

Messages (3)
msg190274 - (view) Author: Andreas Jung (Andreas.Jung) Date: 2013-05-29 06:24
I tried to install 2.7.5 on my OpenSuse 12.2 (latest patches)

ajung@blackmoon2:~/sandboxes/mib.portal> cat /etc/issue
Welcome to openSUSE 12.2 "Mantis" - Kernel \r (\l).


Compilation went fine (no visible errors).

Starting the interpreter gives me:

ajung@blackmoon2:~/sandboxes/mib.portal> /opt/python-2.7.5/bin/python 
Could not find platform dependent libraries <exec_prefix>
Consider setting $PYTHONHOME to <prefix>[:<exec_prefix>]
Python 2.7.5 (default, May 29 2013, 08:19:10) 
[GCC 4.7.1 20120723 [gcc-4_7-branch revision 189773]] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> 

Trying to bootstrap a Pyramid project using zc.buildout gives me:

ajung@blackmoon2:~/sandboxes/mib.portal> /opt/python-2.7.5/bin/python bootstrap.py 
Could not find platform dependent libraries <exec_prefix>
Consider setting $PYTHONHOME to <prefix>[:<exec_prefix>]
Traceback (most recent call last):
  File "bootstrap.py", line 21, in <module>
    import os, shutil, sys, tempfile, urllib, urllib2, subprocess
  File "/opt/python-2.7.5/lib/python2.7/shutil.py", line 12, in <module>
    import collections
  File "/opt/python-2.7.5/lib/python2.7/collections.py", line 8, in <module>
    from _collections import deque, defaultdict
ImportError: No module named _collections
msg190275 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2013-05-29 07:22
Without more information, it is difficult to guess what is going wrong.  Please provide exactly what ./configure options you used to build Python and any "make install" options.  When you start Python, what values do "sys.prefix", "sys.exec_prefix", and "sys.path" have?  Does "python -E" give any different results?
msg198794 - (view) Author: Tom Gross (Tom.Gross) Date: 2013-10-01 17:21
I guess you are on a 64bit os an the issue is a variant of issue1294959. Some of the components (scripts) are installed in the $PREFIX/lib folder and some are (libs) installed in the $PREFIX/lib64 folder. a workaround which worked for me (on OpenSuse 12.3 which faced the same issue) is specifying a lib directory on configure like this:

> ./configure --prefix=/opt/Python275 --libdir=/opt/Python275/lib

All components (scripts & libs) are in the $PREFIX/lib folder then.
History
Date User Action Args
2020-02-12 01:21:56vstinnersetstatus: open -> closed
superseder: Problems with /usr/lib64 builds.
resolution: duplicate
stage: resolved
2013-10-01 17:21:35Tom.Grosssetnosy: + Tom.Gross
messages: + msg198794
2013-05-29 07:22:13ned.deilysetnosy: + ned.deily
messages: + msg190275
2013-05-29 06:25:15Andreas.Jungsetcomponents: + Build
2013-05-29 06:25:00Andreas.Jungcreate