classification
Title: IDLE shell crashes when reporting errors in Windows 7
Type: crash Stage: resolved
Components: IDLE, Windows Versions: Python 3.2
process
Status: closed Resolution: duplicate
Dependencies: Superseder: IDLE and pythonw.exe stderr problem
View: 13582
Assigned To: Nosy List: brian.curtin, kbk, marcopolo, roger.serwy, serhiy.storchaka, terry.reedy, tim.golden
Priority: normal Keywords:

Created on 2013-05-22 02:58 by marcopolo, last changed 2013-05-22 07:05 by serhiy.storchaka. This issue is now closed.

Messages (2)
msg189788 - (view) Author: Marc (marcopolo) Date: 2013-05-22 02:58
Using TkInter as gui, running a module that worked in 3.0 (I believe). 

It is trying to print a warning message about 

RuntimeWarning: overflow encountered in double_scalars

and stops my process (running eval) returning this error

  File "C:\Python32\lib\idlelib\PyShell.py", line 59, in idle_showwarning
    file.write(warnings.formatwarning(message, category, filename,
AttributeError: 'NoneType' object has no attribute 'write'

If I use python -m idlelib.idle it doesn't happen; it just prints the error.

Previously this worked fine using the shell as stdout. This is similar to a bug about symbols' errors however it has been closed and this one is not about symbols. http://bugs.python.org/issue14200

I don't really know a lot about programming and don't often submit bugs so sorry if I've missed any major details here.

Marc
msg189794 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2013-05-22 07:05
This is a duplicate of issue13582.
History
Date User Action Args
2013-05-22 07:05:55serhiy.storchakasetstatus: open -> closed

superseder: IDLE and pythonw.exe stderr problem

nosy: + serhiy.storchaka
messages: + msg189794
resolution: duplicate
stage: resolved
2013-05-22 07:00:54serhiy.storchakasetnosy: + terry.reedy, kbk, tim.golden, roger.serwy, brian.curtin
components: + Windows
2013-05-22 02:58:12marcopolocreate