classification
Title: distutils should access stat_result timestamps via .st_*time attributes
Type: enhancement Stage: resolved
Components: Distutils Versions: Python 3.5
process
Status: closed Resolution: duplicate
Dependencies: Superseder: newer() function in dep_util.py discard changes in the same second
View: 13420
Assigned To: eric.araujo Nosy List: BreamoreBoy, berker.peksag, eric.araujo, jwilk, tarek
Priority: normal Keywords:

Created on 2013-05-20 21:27 by jwilk, last changed 2016-06-09 14:09 by berker.peksag. This issue is now closed.

Messages (3)
msg189695 - (view) Author: Jakub Wilk (jwilk) Date: 2013-05-20 21:27
Currently distutils accesses stat_result timestamps like this:

  os.stat(source)[ST_MTIME]

But, for compatibility with older Python versions, the above method gives you at most 1-second resolution. It should do it like this instead:

  os.stat(source).st_mtime
msg228266 - (view) Author: Mark Lawrence (BreamoreBoy) * Date: 2014-10-02 22:17
@Eric what is your opinion on this?
msg268026 - (view) Author: Berker Peksag (berker.peksag) * (Python committer) Date: 2016-06-09 14:09
This is a duplicate of issue 13420.
History
Date User Action Args
2016-06-09 14:09:06berker.peksagsetstatus: open -> closed

superseder: newer() function in dep_util.py discard changes in the same second

nosy: + berker.peksag
messages: + msg268026
resolution: duplicate
stage: resolved
2014-10-02 22:17:08BreamoreBoysetversions: + Python 3.5
nosy: + BreamoreBoy

messages: + msg228266

type: enhancement
2013-05-20 21:27:22jwilkcreate