classification
Title: distutils - TypeError in command/build_ext.py
Type: Stage: resolved
Components: Distutils Versions: Python 3.4
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: eric.araujo Nosy List: Arfrever, doko, eric.araujo, giampaolo.rodola, tarek
Priority: normal Keywords:

Created on 2013-04-29 20:10 by giampaolo.rodola, last changed 2013-04-29 20:51 by eric.araujo. This issue is now closed.

Messages (4)
msg188092 - (view) Author: Giampaolo Rodola' (giampaolo.rodola) * (Python committer) Date: 2013-04-29 20:10
Traceback (most recent call last):
  File "setup.py", line 221, in <module>
    ...  and much more ;)"""
  File "/home/giampaolo/svn/python/3.4/Lib/distutils/core.py", line 148, in setup
    dist.run_commands()
  File "/home/giampaolo/svn/python/3.4/Lib/distutils/dist.py", line 917, in run_commands
    self.run_command(cmd)
  File "/home/giampaolo/svn/python/3.4/Lib/distutils/dist.py", line 936, in run_command
    cmd_obj.run()
  File "/home/giampaolo/svn/python/3.4/Lib/distutils/command/build.py", line 126, in run
    self.run_command(cmd_name)
  File "/home/giampaolo/svn/python/3.4/Lib/distutils/cmd.py", line 313, in run_command
    self.distribution.run_command(command)
  File "/home/giampaolo/svn/python/3.4/Lib/distutils/dist.py", line 936, in run_command
    cmd_obj.run()
  File "/home/giampaolo/svn/python/3.4/Lib/distutils/command/build_ext.py", line 349, in run
    self.build_extensions()
  File "/home/giampaolo/svn/python/3.4/Lib/distutils/command/build_ext.py", line 458, in build_extensions
    self.build_extension(ext)
  File "/home/giampaolo/svn/python/3.4/Lib/distutils/command/build_ext.py", line 474, in build_extension
    ext_path = self.get_ext_fullpath(ext.name)
  File "/home/giampaolo/svn/python/3.4/Lib/distutils/command/build_ext.py", line 633, in get_ext_fullpath
    filename = self.get_ext_filename(modpath[-1])
  File "/home/giampaolo/svn/python/3.4/Lib/distutils/command/build_ext.py", line 672, in get_ext_filename
    return os.path.join(*ext_path) + ext_suffix
TypeError: Can't convert 'NoneType' object to str implicitly


I'm getting this while building PyOpenSSL on Linux with laterst cset of Python 3.4.
Everything's fine on Python 3.3.
Possibly related with issue #16754?
msg188097 - (view) Author: Arfrever Frehtes Taifersar Arahesis (Arfrever) * (Python triager) Date: 2013-04-29 20:44
Your Python seems to be built incorrectly. Maybe you forgot to re-run './configure ...; make' after updating working copy. Could you try in a new working copy?

(I cannot reproduce this bug.)
msg188099 - (view) Author: Giampaolo Rodola' (giampaolo.rodola) * (Python committer) Date: 2013-04-29 20:50
I'm sorry, you're right.
msg188100 - (view) Author: Éric Araujo (eric.araujo) * (Python committer) Date: 2013-04-29 20:51
:)
History
Date User Action Args
2013-04-29 20:51:23eric.araujosetmessages: + msg188100
stage: resolved
2013-04-29 20:50:33giampaolo.rodolasetstatus: open -> closed
resolution: not a bug
messages: + msg188099
2013-04-29 20:44:45Arfreversetnosy: + Arfrever
messages: + msg188097
2013-04-29 20:10:21giampaolo.rodolacreate