classification
Title: can't compile with clang and build a shared lib due to libffi
Type: compile error Stage: resolved
Components: Build Versions: Python 3.4, Python 3.5
process
Status: closed Resolution: out of date
Dependencies: Superseder:
Assigned To: Nosy List: amaury.forgeotdarc, belopolsky, matrixsystem, meador.inge, ned.deily
Priority: normal Keywords:

Created on 2013-04-26 07:32 by matrixsystem, last changed 2020-05-08 02:11 by ned.deily. This issue is now closed.

Files
File name Uploaded Description Edit
mywork.pitch matrixsystem, 2013-04-26 07:32 review
Messages (4)
msg187838 - (view) Author: leon zheng (matrixsystem) Date: 2013-04-26 07:32
build with prefix point to a arbitrary path, can't find the dynamic lib,
and libffi upstream bug:
./configure --prefix=xxx --enable-shared --enable-ipv6 --with-threads CC=clang
msg228265 - (view) Author: Mark Lawrence (BreamoreBoy) * Date: 2014-10-02 22:13
The patch changes four lines in Modules/_ctypes/libffi/configure.ac which means nothing to me, can someone review it please.
msg228330 - (view) Author: Alexander Belopolsky (belopolsky) * (Python committer) Date: 2014-10-03 16:16
Leon,

Are you trying to run compiled python binary before it was installed?  If so, this is expected and not specific to clang or libffi.

If your issue is something else - please explain how to reproduce it and post the error messages that you see.
msg368401 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2020-05-08 02:11
As of Python 3.7, Python source releases no longer "vendor" the source of libffi for Linux platforms; you need to use either a system-supplied libffi or, if really necessary, build and link with your own copy (not always easy to do). As the supplied patch modifies the now-defunct vendored libffi source, this issue is no longer relevant for current Pythons.
History
Date User Action Args
2020-05-08 02:11:29ned.deilysetstatus: open -> closed

nosy: + ned.deily
messages: + msg368401

resolution: out of date
stage: resolved
2020-03-06 20:14:29brett.cannonsetnosy: - brett.cannon
2019-04-26 18:08:35BreamoreBoysetnosy: - BreamoreBoy
2014-10-03 16:16:42belopolskysetmessages: + msg228330
2014-10-03 13:03:22brett.cannonsetnosy: + amaury.forgeotdarc, belopolsky, meador.inge
2014-10-03 13:02:56brett.cannonsettitle: issue about compile with clang and build a shared lib -> can't compile with clang and build a shared lib due to libffi
2014-10-03 02:03:32pitrousetnosy: + brett.cannon
2014-10-02 22:13:39BreamoreBoysetnosy: + BreamoreBoy

messages: + msg228265
versions: + Python 3.5
2013-04-26 07:32:26matrixsystemcreate