classification
Title: Segfault closing a file from concurrent threads
Type: Stage:
Components: None Versions: Python 2.5
process
Status: closed Resolution: duplicate
Dependencies: Superseder: thread unsafe file objects cause crash
View: 815646
Assigned To: Nosy List: fijal, georg.brandl
Priority: normal Keywords:

Created on 2007-08-21 08:08 by fijal, last changed 2007-08-28 18:33 by georg.brandl. This issue is now closed.

Messages (2)
msg32673 - (view) Author: Maciek Fijalkowski (fijal) Date: 2007-08-21 08:08
On linux box this piece of code segfaults (CPy 2.5.1)

while 1:
    f = open("/tmp/dupa", "w")
    thread.start_new_thread(f.close, ())
    f.close()
msg55381 - (view) Author: Georg Brandl (georg.brandl) * (Python committer) Date: 2007-08-28 18:33
Actually, this is a dupe of #815646.
History
Date User Action Args
2007-08-28 18:33:45georg.brandlsetstatus: open -> closed
resolution: duplicate
superseder: thread unsafe file objects cause crash
messages: + msg55381
nosy: + georg.brandl
2007-08-21 08:08:21fijalcreate