classification
Title: http://docs.python.org/2.7/objects.inv doesn't support :func:`repr` or :exc:`Exception`
Type: Stage: resolved
Components: Documentation Versions: Python 2.7
process
Status: closed Resolution: out of date
Dependencies: Superseder:
Assigned To: docs@python Nosy List: BreamoreBoy, asvetlov, docs@python, eric.araujo, georg.brandl, ras
Priority: normal Keywords:

Created on 2013-04-13 07:18 by ras, last changed 2014-07-23 10:11 by asvetlov. This issue is now closed.

Files
File name Uploaded Description Edit
bug.rst ras, 2013-04-13 07:18 bug.rst
conf.py ras, 2013-04-13 07:19 conf2.7/conf.py
conf.py ras, 2013-04-13 07:20 conf3.2/conf.py
Messages (3)
msg186697 - (view) Author: Russell Stuart (ras) Date: 2013-04-13 07:18
.. topic:: http://docs.python.org/2.7/objects.inv doesn't support :func:`repr` or :exc:`Exception`

  A bug report for Python 2.7's docs.

.. _intro:

Bug
===

Running::

  sphinx-build -c conf2.7 -n -b html -E . html

Produces::

  Running Sphinx v1.1.3
  loading intersphinx inventory from http://docs.python.org/2.7/objects.inv...
  building [html]: targets for 1 source files that are out of date
  updating environment: 1 added, 0 changed, 0 removed
  reading sources... [100%] bug                                                                             
  looking for now-outdated files... none found
  pickling environment... done
  checking consistency... done
  preparing documents... done
  writing output... [100%] bug                                                                              
  /home/rstuart/zzz/bug.rst:1: WARNING: py:exc reference target not found: Exception
  /home/rstuart/zzz/bug.rst:1: WARNING: py:func reference target not found: repr
  writing additional files... genindex search
  copying static files... done
  dumping search index... done
  dumping object inventory... done
  build succeeded, 2 warnings.

Note the ``WARNING`` lines.  They should not be there.

Running::

  sphinx-build -c conf3.2 -b html -n -E . html

Produces::

  Running Sphinx v1.1.3
  loading intersphinx inventory from http://docs.python.org/3.2/objects.inv...
  building [html]: targets for 1 source files that are out of date
  updating environment: 1 added, 0 changed, 0 removed
  reading sources... [100%] bug                                                                             
  looking for now-outdated files... none found
  pickling environment... done
  checking consistency... done
  preparing documents... done
  writing output... [100%] bug                                                                              
  writing additional files... genindex search
  copying static files... done
  dumping search index... done
  dumping object inventory... done
  build succeeded.

I presume this means something is wrong with 
http://docs.python.org/2.7/objects.inv it downloads.

``conf2.7.py``:

  .. include:: conf2.7/conf.py
    :literal:

``conf3.2.py``:

  .. include:: conf3.2/conf.py
    :literal:
msg223475 - (view) Author: Mark Lawrence (BreamoreBoy) * Date: 2014-07-19 20:38
I don't understand this at all, but if this is a Sphinx bug shouldn't it be reported on the appropriate bug tracker and not here?
msg223733 - (view) Author: Andrew Svetlov (asvetlov) * (Python committer) Date: 2014-07-23 10:11
Cannot reproduce.
History
Date User Action Args
2014-07-23 10:11:30asvetlovsetstatus: open -> closed

nosy: + asvetlov
messages: + msg223733

resolution: out of date
stage: resolved
2014-07-19 20:38:51BreamoreBoysetnosy: + BreamoreBoy
messages: + msg223475
2013-04-13 08:00:11eric.araujosetnosy: + georg.brandl, eric.araujo
2013-04-13 07:20:09rassetfiles: + conf.py
2013-04-13 07:19:36rassetfiles: + conf.py
2013-04-13 07:18:44rascreate