classification
Title: Python - Operation time out problem
Type: behavior Stage: resolved
Components: Library (Lib) Versions: Python 2.6
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: ajaksu2, mohammedsk
Priority: normal Keywords:

Created on 2007-08-06 22:43 by mohammedsk, last changed 2009-04-25 21:38 by ajaksu2. This issue is now closed.

Files
File name Uploaded Description Edit
search_all.py mohammedsk, 2007-08-06 22:43 Script uses Medline record parser pub med dictionary
Messages (2)
msg32592 - (view) Author: MASK (mohammedsk) Date: 2007-08-06 22:43
I have a program that reads from a file some search terms. The script uses Medline record parser pub med dictionary.
Since I search so many terms, the script times out. Here is the error:

Traceback (most recent call last):
File "(stdin)", line1, in <module>
File "search_all.py",line71, in <module>
Cur_record = medline_dict [id]
File "C:\Python25\Lib\site-packages\PubMed.py", line 103,
in_getitem_raise Key Error,x
Key Error: IOError('socket error',error(10060,'Operation timed out'))

I looked online for solutions and one solution was to add the following to the script:

import socket
socket.setdefaulttimeout(value)


But this code did not do anything, the script continues on timing out. 

A complete Python script is attached.

Any help is appreciated.

Thanks,
Mohammed
msg85683 - (view) Author: Daniel Diniz (ajaksu2) (Python triager) Date: 2009-04-07 04:03
Unless someone can spot a Python bug here, this issue will be closed.
History
Date User Action Args
2009-04-25 21:38:26ajaksu2setstatus: pending -> closed
resolution: not a bug
stage: test needed -> resolved
2009-04-07 04:03:51ajaksu2setstatus: open -> pending

type: behavior

title: Python - Operation time out problem -> Python - Operation time out problem
nosy: + ajaksu2
versions: + Python 2.6, - Python 2.5
messages: + msg85683
stage: test needed
2007-08-06 22:43:17mohammedskcreate