classification
Title: IDLE: Add clear-window option to the Shell menu.
Type: enhancement Stage:
Components: IDLE Versions: Python 3.4
process
Status: closed Resolution: duplicate
Dependencies: Superseder: IDLE - an extension to clear the shell window
View: 6143
Assigned To: Nosy List: rhettinger, roger.serwy
Priority: normal Keywords: easy

Created on 2013-04-04 05:59 by rhettinger, last changed 2013-04-04 13:45 by roger.serwy. This issue is now closed.

Messages (2)
msg186004 - (view) Author: Raymond Hettinger (rhettinger) * (Python committer) Date: 2013-04-04 05:59
Without a restart-and-clear option, the shell window tends to grow without bound, becoming increasingly lethargic along the way.

I've have recurring student requests for this minor feature.
msg186032 - (view) Author: Roger Serwy (roger.serwy) * (Python committer) Date: 2013-04-04 13:45
This is a different spin on issue6143. Here the suggestion is to combine the clear function with the restart option for a new menu option.

I am closing this one as a duplicate of #6143, but adding the Shell "restart and clear" suggestion.
History
Date User Action Args
2013-04-04 13:45:43roger.serwysetstatus: open -> closed

nosy: + roger.serwy
messages: + msg186032

superseder: IDLE - an extension to clear the shell window
resolution: duplicate
2013-04-04 05:59:59rhettingercreate