classification
Title: unittest.mock: test_create_autospec_unbound_methods is skipped
Type: Stage:
Components: Library (Lib), Tests Versions: Python 3.4, Python 3.5
process
Status: closed Resolution: out of date
Dependencies: Superseder:
Assigned To: Nosy List: BreamoreBoy, ezio.melotti, michael.foord, vstinner
Priority: normal Keywords:

Created on 2013-03-25 23:58 by vstinner, last changed 2015-10-02 21:10 by vstinner. This issue is now closed.

Messages (3)
msg185249 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2013-03-25 23:58
While working on #17516, I saw that test_create_autospec_unbound_methods() of Lib/unittest/test/testmock/testhelpers.py is skipped:

    def test_create_autospec_unbound_methods(self):
        # see mock issue 128
        # this is expected to fail until the issue is fixed
        return

Related entry in mock bug tracker:
http://code.google.com/p/mock/issues/detail?id=128

If it is not necessary to duplicate the issue here, please just close it.
msg185253 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2013-03-26 00:00
Oh, there is another skipped test in Lib/unittest/test/testmock/testpatch.py:

    def test_patch_descriptor(self):
        # would be some effort to fix this - we could special case the
        # builtin descriptors: classmethod, property, staticmethod
        return
msg223794 - (view) Author: Mark Lawrence (BreamoreBoy) * Date: 2014-07-23 23:22
Both of these tests are still commented out in the default branch.
History
Date User Action Args
2015-10-02 21:10:37vstinnersetstatus: open -> closed
resolution: out of date
2014-07-23 23:22:31BreamoreBoysetnosy: + BreamoreBoy

messages: + msg223794
versions: + Python 3.5, - Python 3.3
2013-03-30 03:57:51ezio.melottisetnosy: + ezio.melotti
2013-03-26 00:00:30vstinnersetmessages: + msg185253
2013-03-25 23:58:28vstinnercreate