classification
Title: AMD64 installer does not place python25.dll in system dir
Type: Stage:
Components: Installation Versions:
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: loewis Nosy List: loewis, quiver, rupole
Priority: normal Keywords:

Created on 2007-07-03 02:02 by rupole, last changed 2007-09-02 19:02 by loewis. This issue is now closed.

Files
File name Uploaded Description Edit
msi.log.zip rupole, 2007-07-03 02:02
Messages (6)
msg32441 - (view) Author: Roger Upole (rupole) Date: 2007-07-03 02:02
Even with All Users selected, the 2.5.1 AMD64 msi installer puts python25.dll in the base python directory.  Attaching install log.

msg32442 - (view) Author: Roger Upole (rupole) Date: 2007-07-03 02:17
This looks like a simple typo in msi.py:
if msilib.Win64:
    SystemFolderName = "[SystemFolder64]"

It should be System64Folder instead.

msg32443 - (view) Author: George Yoshida (quiver) (Python committer) Date: 2007-07-03 02:49
Martin, can you take a look?
msg32444 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2007-07-03 05:49
Will do. Most likely, rupole is right with his analysis.
msg55499 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2007-08-30 18:39
I have now fixed it in 57750, 57751, 57754. I leave the bug open until I
can actually test it.
msg55587 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2007-09-02 19:02
Mark Hammond has now confirmed it worked for 3.0a1, so closing it.
History
Date User Action Args
2007-09-02 19:02:34loewissetstatus: open -> closed
messages: + msg55587
2007-08-30 18:39:20loewissetresolution: fixed
messages: + msg55499
2007-07-03 02:02:31rupolecreate