classification
Title: Сrash when deleting deeply recursive iterator wrappers
Type: crash Stage: resolved
Components: Extension Modules Versions: Python 3.2, Python 3.3, Python 3.4, Python 2.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder: deeply nested itertools objects segfault
View: 14010
Assigned To: serhiy.storchaka Nosy List: rhettinger, serhiy.storchaka
Priority: normal Keywords:

Created on 2013-02-26 10:28 by serhiy.storchaka, last changed 2013-02-26 10:40 by serhiy.storchaka. This issue is now closed.

Messages (3)
msg183041 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2013-02-26 10:28
http://permalink.gmane.org/gmane.comp.python.ideas/19669

>>> from itertools import islice, count
>>> it = count()
>>> for i in range(1000000):
...     it = islice(it, 0)
... 
>>> del it
Segmentation fault

This looks very similar to the crash in tee() (issue13454).
msg183042 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2013-02-26 10:36
And same issue with filter:

>>> it = iter([])
>>> for i in range(1000000):
...     it = filter(None, it)
... 
>>> del it
Segmentation fault
msg183043 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2013-02-26 10:40
Aha, this is a duplicate of issue14010.
History
Date User Action Args
2013-02-26 10:40:16serhiy.storchakasetstatus: open -> closed
superseder: deeply nested itertools objects segfault
messages: + msg183043

resolution: duplicate
stage: needs patch -> resolved
2013-02-26 10:36:47serhiy.storchakasetmessages: + msg183042
title: Сrash when deleting deeply recursive islice() -> Сrash when deleting deeply recursive iterator wrappers
2013-02-26 10:28:15serhiy.storchakacreate