classification
Title: Allow float('infinity') as well as float('inf')
Type: enhancement Stage:
Components: Interpreter Core Versions: Python 3.0, Python 2.6
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: mark.dickinson
Priority: normal Keywords:

Created on 2008-01-03 19:39 by mark.dickinson, last changed 2008-01-03 20:33 by gvanrossum. This issue is now closed.

Messages (2)
msg59146 - (view) Author: Mark Dickinson (mark.dickinson) * (Python committer) Date: 2008-01-03 19:39
This request relates to issue 1635:

http://bugs.python.org/issue1635

which allows cross-platform creation of infinities and nans.
The IEEE754 standard, the C99 standard, and the standard on which 
Decimal is based all allow creation of an infinity from the string 
'Infinity' (case-independent), as well as from 'inf'.  Is there any 
reason not to allow this for floats?  I'm happy to create a patch.
msg59149 - (view) Author: Mark Dickinson (mark.dickinson) * (Python committer) Date: 2008-01-03 19:50
Sorry:  brain not working.  Please close as invalid.
History
Date User Action Args
2008-01-03 20:33:52gvanrossumsetstatus: open -> closed
resolution: not a bug
2008-01-03 19:50:19mark.dickinsonsetmessages: + msg59149
2008-01-03 19:39:27mark.dickinsoncreate