classification
Title: Reading source code from file on exception
Type: behavior Stage:
Components: Interpreter Core Versions: Python 2.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Unupdated source file in traceback
View: 8087
Assigned To: Nosy List: Mezgrman, flox
Priority: normal Keywords:

Created on 2013-02-12 18:16 by Mezgrman, last changed 2013-02-12 19:21 by flox. This issue is now closed.

Messages (2)
msg181971 - (view) Author: Julian (Mezgrman) Date: 2013-02-12 18:16
When an exception occurs and a traceback is printed, the source code is read from the file which leads to confusion when the file has been modified, but the code that produced the exception still had the old code in memory.
msg181972 - (view) Author: Florent Xicluna (flox) * (Python committer) Date: 2013-02-12 19:21
Duplicate of #8087
History
Date User Action Args
2013-02-12 19:21:07floxsetstatus: open -> closed

nosy: + flox
messages: + msg181972

superseder: Unupdated source file in traceback
resolution: duplicate
2013-02-12 18:16:50Mezgrmancreate