classification
Title: Disable TIPC in configure
Type: Stage:
Components: Build Versions: Python 2.7
process
Status: closed Resolution: wont fix
Dependencies: Superseder:
Assigned To: Nosy List: ddvento@ucar.edu, pitrou
Priority: normal Keywords:

Created on 2013-01-31 17:12 by ddvento@ucar.edu, last changed 2013-02-04 18:09 by ddvento@ucar.edu. This issue is now closed.

Messages (4)
msg181037 - (view) Author: (ddvento@ucar.edu) Date: 2013-01-31 17:12
This is related to Issue17085 and Issue1646

My system is a cluster Red Hat Enterprise Linux Server release 6.2 (Santiago) and it happens to have /usr/include/linux/tipc.h but probably tipc disabled in the kernel for some reasons which I ignore. There is little interest and no time from the sysadministrators to investigate TIPC, or to remove unneeded files or packages.

When I configure and build Python 2.7.3, it seems to  build correctly. However the test suite crashes as described in Issue17085.

Therefore, I want to rebuild Python 2.7.3 with TIPC disabled. Unfortunately, configure seems to ignore all of the followings:

./configure --without-tipc
./configure --without-TIPC
HAVE_LINUX_TIPC_H=0 ./configure
HAVE_LINUX_TIPC_H=0 ./configure HAVE_LINUX_TIPC_H=0

(for the record, my other configure options are --enable-shared --with-system-expat --prefix=my-path)

I also tried to manually editing config.status as follows:

--- config.status.orig  2013-01-31 09:24:04.109311726 -0700
+++ config.status       2013-01-31 09:28:28.397660288 -0700
@@ -854,7 +854,7 @@
 D["HAVE_SYS_RESOURCE_H"]=" 1"
 D["HAVE_NETPACKET_PACKET_H"]=" 1"
 D["HAVE_SYSEXITS_H"]=" 1"
-D["HAVE_LINUX_TIPC_H"]=" 1"
+D["HAVE_LINUX_TIPC_H"]=" 0"
 D["HAVE_SPAWN_H"]=" 1"
 D["HAVE_DIRENT_H"]=" 1"
 D["HAVE_TERM_H"]=" 1"

then run it and check that pyconfig.h has #define HAVE_LINUX_TIPC_H 0 (which it did). Running make and make test after this, produces exactly the same issue as described in Issue17085.

Is there a way to force configure to ignore TIPC?
msg181039 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2013-01-31 18:28
Why would you disable TIPC? If TIPC crashes the test suite, you probably have a system bug. I would suggest you try to diagnose what happens exactly.
(normally, the TIPC tests are skipped if the tipc kernel module isn't loaded)
msg181040 - (view) Author: (ddvento@ucar.edu) Date: 2013-01-31 18:52
Antoine, the exact reason why I want to disable TIPC in configure, is 
that either the test suite or the TIPC test case or both has/have a bug 
(not my system). Therefore I suggest that you re-post your comment in 
Issue17085, and I'll be happy to provide more details that would be 
off-topic here.

However, regardless of my particular needs, disabling TIPC in configure 
is something useful for a variety of other reasons (e.g. one having a 
functional TIPC but not wanting to have it enabled in python), and 
therefore I asked it here.
It is customary to have autotools being able to individually select 
packages that one wants or does not want to use. In fact ./configure 
--help reports the --without-PACKAGE option which does not work for TIPC 
and this is the bug of present Issue17092
msg181361 - (view) Author: (ddvento@ucar.edu) Date: 2013-02-04 18:09
Ok, I'm closing this ticket, since it does not seem there is interested in fixing it. I still believe it would be a nice feature, but life is short, let's concentrate efforts on more useful things.

Moreover (see Issue17085 for details) TIPC was not the root cause of the that other issue.
History
Date User Action Args
2013-02-04 18:09:50ddvento@ucar.edusetstatus: open -> closed
resolution: wont fix
messages: + msg181361
2013-01-31 18:52:54ddvento@ucar.edusetmessages: + msg181040
2013-01-31 18:28:54pitrousetnosy: + pitrou
messages: + msg181039
2013-01-31 17:12:52ddvento@ucar.educreate