classification
Title: Fix sporadic buildbot failures for test_mailbox
Type: behavior Stage: resolved
Components: Tests Versions: Python 3.2, Python 3.3, Python 3.4, Python 2.7
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: Nosy List: jkloth, python-dev, r.david.murray
Priority: normal Keywords: patch

Created on 2013-01-28 17:14 by jkloth, last changed 2013-02-11 15:15 by r.david.murray. This issue is now closed.

Files
File name Uploaded Description Edit
test_mailbox.diff jkloth, 2013-01-28 17:14 review
Messages (6)
msg180862 - (view) Author: Jeremy Kloth (jkloth) * Date: 2013-01-28 17:14
Attached is an attempt at fixing the sporadic failures of test_mailbox on the AMD64 Windows buildbot.

It fails due to access errors on some directories which leads me to believe the helper functions in test.support should fix the problem.
msg180864 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2013-01-28 17:27
I think the support functions just ignore errors.  Isn't this going to continue to leave garbage on the buildbot filesystem without fixing the underlying problem?  I wonder if this is a variation on the usual Windows access errors, in which case perhaps that is the best we can do...
msg180868 - (view) Author: Jeremy Kloth (jkloth) * Date: 2013-01-28 18:00
Actually, the support functions (as of 3.3) attempt to work around the access errors.  They attempt to wait (to a point) for a successful operation before returning to the caller.  See issue15496 for details.

It is usually the case that the previous operation has not yet finished as to the cause of the access error.
msg180875 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2013-01-28 19:34
Ah, excellent.  I had missed that change.

This looks good then.  Hopefully it will work :)
msg181896 - (view) Author: Roundup Robot (python-dev) (Python triager) Date: 2013-02-11 15:14
New changeset bbeff2958cc5 by R David Murray in branch '3.2':
#17064: fix sporadic permission errors in test_mailbox on windows.
http://hg.python.org/cpython/rev/bbeff2958cc5

New changeset 3e3915cbfde3 by R David Murray in branch '3.3':
Merge: #17064: fix sporadic permission errors in test_mailbox on windows.
http://hg.python.org/cpython/rev/3e3915cbfde3

New changeset aa15df77e58f by R David Murray in branch 'default':
Merge: #17064: fix sporadic permission errors in test_mailbox on windows.
http://hg.python.org/cpython/rev/aa15df77e58f

New changeset 1c2dbed859ca by R David Murray in branch '2.7':
#17064: fix sporadic permission errors in test_mailbox on windows.
http://hg.python.org/cpython/rev/1c2dbed859ca
msg181897 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2013-02-11 15:15
Thanks, Jeremy.
History
Date User Action Args
2013-02-11 15:15:46r.david.murraysetstatus: open -> closed
versions: + Python 2.7, Python 3.2, - Python 3.5
type: behavior
messages: + msg181897

resolution: fixed
stage: resolved
2013-02-11 15:14:49python-devsetnosy: + python-dev
messages: + msg181896
2013-01-28 19:34:29r.david.murraysetmessages: + msg180875
2013-01-28 18:00:24jklothsetmessages: + msg180868
2013-01-28 17:27:09r.david.murraysetnosy: + r.david.murray
messages: + msg180864
2013-01-28 17:14:19jklothcreate