classification
Title: IDLE -- jump to home should not go past the PS1 and PS2 prompts
Type: enhancement Stage: resolved
Components: IDLE Versions: Python 3.3, Python 3.4, Python 2.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder: IDLE: Mac OS X pressing ctrl-A in Python shell moved cursor before the prompt, which then makes the keyboard unresponsive.
View: 18444
Assigned To: Nosy List: markroseman, rhettinger, roger.serwy, terry.reedy
Priority: normal Keywords:

Created on 2013-01-28 09:17 by rhettinger, last changed 2017-06-19 20:45 by terry.reedy. This issue is now closed.

Messages (4)
msg180841 - (view) Author: Raymond Hettinger (rhettinger) * (Python committer) Date: 2013-01-28 09:17
In IDLE's shell, pressing <home> or <control-a> currently jumps to the beginning of a line.   Instead it should stop *after* the ">>> "  prompt.
msg181155 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2013-02-02 09:53
On my Win 7 system, with 3.3.0, the first Home sends the cursor to the beginning of the user entry, after '>>> '. The second sends it to the beginning of the display line. And so forth, as intended. See #3851. (It worked the same with Win xp and 3.1) If are getting different behavior, what os and py versions?
msg185883 - (view) Author: Roger Serwy (roger.serwy) * (Python committer) Date: 2013-04-03 04:07
When using the IDLE Classic OSX key set, the "beginning-of-line" virtual event gets bound to <Control-Key-Left>. Using this key set I can repeat the behavior that Raymond observed.

The .home_callback() in Lib/idlelib/EditorWindow.py contains the logic from #3851 for placing the cursor at the beginning of the prompt, but it requires that a key combination be bound to the beginning-of-line virtual event.

Should we append "<Key-Home> <Control-Key-a>" to the begining-of-line config in Lib/idlelib/config-keys.def ?
msg296373 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2017-06-19 20:45
I am closing this instead of #18444 because the latter has more extensive discussion.
History
Date User Action Args
2017-06-19 20:45:59terry.reedysetstatus: open -> closed
superseder: IDLE: Mac OS X pressing ctrl-A in Python shell moved cursor before the prompt, which then makes the keyboard unresponsive.
messages: + msg296373

resolution: duplicate
stage: resolved
2015-09-18 16:30:34markrosemansetnosy: + markroseman
2013-04-03 04:07:27roger.serwysetversions: + Python 3.4, - Python 3.1, Python 3.2
nosy: + roger.serwy

messages: + msg185883

type: behavior -> enhancement
2013-02-02 09:53:25terry.reedysetnosy: + terry.reedy
messages: + msg181155
2013-01-28 09:17:44rhettingercreate