classification
Title: Support Visual Studio 2012
Type: enhancement Stage:
Components: Build, Windows Versions: Python 3.5
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Update PCBuild for VS 2015
View: 22919
Assigned To: Nosy List: BreamoreBoy, brian.curtin, cowwoc, steve.dower, tim.golden, trent, zach.ware
Priority: normal Keywords:

Created on 2013-01-27 23:52 by cowwoc, last changed 2014-12-31 20:52 by steve.dower. This issue is now closed.

Messages (6)
msg180808 - (view) Author: Gili T. (cowwoc) Date: 2013-01-27 23:52
msvc9compiler needs to check for the VS110COMNTOOLS environment variable in order to support Visual Studio 2012. Currently it complains "cannot find vcvarsall.bat".

The following workaround works for now:

SET VS90COMNTOOLS=%VS110COMNTOOLS%
msg180810 - (view) Author: Brian Curtin (brian.curtin) * (Python committer) Date: 2013-01-28 00:08
This change can only happen on 3.4.
msg180826 - (view) Author: Gili T. (cowwoc) Date: 2013-01-28 05:52
Why? :)

I ask because all the application I depend upon only run against Python 2.x (Rhodecode, Mercurial, etc). I'd love for them to upgrade but it's not really in my control.

Has there been some sort of policy change within Python to stop supporting 2.x?
msg180828 - (view) Author: Brian Curtin (brian.curtin) * (Python committer) Date: 2013-01-28 05:55
This is a feature request and new features are only being added on the 3.x line. The next feature release will be 3.4.
msg223037 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2014-07-14 15:43
msvc9compiler should not look for any versions of MSVC other than 9.0, since extensions built using other versions will be subtly (or dramatically) incompatible with Python unless you also rebuild Python itself with the same MSVC version.

You can set DISTUTILS_USE_SDK=1 and run from the VS 2012 Developer Command Prompt (or otherwise configure your environment) if you are willing to accept the risk, but ensure you test the built extension thoroughly.

Hopefully, 3.5 will switch to the next version of MSVC (14) and will be able to detect and use all later releases, so this particular problem won't exist in the future. There's nothing we can/will do for 2.x at this stage.
msg233270 - (view) Author: Mark Lawrence (BreamoreBoy) * Date: 2014-12-31 19:31
Can this be closed as essentially a duplicate of #22919 which targets Visual Studio 2015?
History
Date User Action Args
2014-12-31 20:52:10steve.dowersetstatus: open -> closed
superseder: Update PCBuild for VS 2015
resolution: duplicate
2014-12-31 19:31:35BreamoreBoysetnosy: + BreamoreBoy
messages: + msg233270
2014-07-14 15:43:12steve.dowersetmessages: + msg223037
2014-07-10 22:30:39BreamoreBoysetnosy: + tim.golden, zach.ware, steve.dower

versions: + Python 3.5, - Python 3.4
2013-01-30 10:18:49trentsetnosy: + trent
2013-01-28 05:55:46brian.curtinsetmessages: + msg180828
2013-01-28 05:52:35cowwocsetmessages: + msg180826
2013-01-28 00:08:29brian.curtinsetmessages: + msg180810
versions: + Python 3.4, - Python 2.7
2013-01-27 23:54:34ezio.melottisetnosy: + brian.curtin
components: + Windows
2013-01-27 23:52:19cowwoccreate